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1 Introduction to HP Matrix Operating Environment
This document provides an overview of HP Matrix Operating Environment.
• Chapter 1 describes the product features and the available configurations.

• Chapter 2 (page 15) describes the licensing model and license management procedures.

• Chapter 3 (page 20) describes initial setup steps to get started with Matrix OE.

• Chapter 4 (page 32) describes the tools available to set up managed systems correctly and
diagnose and correct common configuration problems.

• Chapter 5 (page 36) provides a list of support resources and a comprehensive list of Matrix
OE documentation.

• The Command reference (page 41) provides command reference pages for the vseassist(1M)
and vselicense(1M) commands that are mentioned elsewhere in this document.

• The Glossary (page 52) provides definitions of key terms used in this document. Initial
occurrences of terms with glossary definitions appear in italics. If you are viewing this document
in electronic form, click the italicized term to jump to the glossary definition.

Matrix OE is an integrated command center that enables you to continuously analyze and optimize
your adaptive infrastructure. It builds on the HP infrastructure management portfolio, including HP
Systems Insight Manager (HP SIM) and HP Insight Management.
Matrix OE provides an integrated graphical environment for managing physical servers, logical
servers, virtual machines, server blades, nPartitions, virtual partitions, applications, and workloads.
You can dynamically re-size virtual servers and migrate resources where they are needed, based
on service-level objectives and business requirements.
For information about the changes in this release of Matrix OE, see the HP Matrix Operating
Environment Release Notes. For a complete list of Matrix OE documentation and the web sites
where these documents can be found, see “Related information” (page 36).

IMPORTANT: The information in the following sections is a summary. Specific supported hardware
and software configurations are provided in the HP Insight Management Support Matrix , available
at http://www.hp.com/go/matrixoe/docs.

Components of HP Matrix Operating Environment
The Matrix OE software is installed on a Central Management Server (CMS) running Systems
Insight Manager, which provides a browser-based user interface. A single CMS can be used to
manage different types of systems. The software is installed on the CMS once, regardless of how
many or what types of managed system licenses are purchased. The following CMS installations
are supported:

• Matrix OE can be installed on the following types of CMS running Microsoft Windows:
HP ProLiant server◦

◦ HP BladeSystem c-Class ProLiant server blade

◦ Virtual machine running under VMware ESX or Microsoft Hyper-V on HP ProLiant or
supported non-HP server

On a CMS running Microsoft Windows, Matrix OE is installed as part of the Insight
Management software family of products. For installation and configuration information, see
the HP Insight Management Preinstallation Worksheet, HP Insight Management Quick
Installation Guide, and HP Insight Management Installation and Configuration Guide. For an
introduction to Insight Management software, including security recommendations, summary
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of included products, and documentation roadmap, see HP Insight Management Getting
Started Guide.

• Matrix OE can be installed on the following types of CMS running HP-UX:
HP Integrity server◦

◦ HP Integrity server blade

◦ virtual machine running under HP Integrity Virtual Machines
For installation on a CMS running HP-UX, see HP Matrix Operating Environment for HP-UX
Installation and Configuration Guide.

The following sections summarize the major software components of Matrix OE. For more
information, see the user guides and other documents listed in “Related information” (page 36).
Help is also available within the software by clicking the button in the upper right of most screens.

HP Matrix OE visualization
Matrix OE visualization provides the framework for visualizing your virtual server environment. All
of the systems and workloads that you are authorized to view are displayed in graphical views.
The hierarchical relationships between systems is displayed in the Visualization view. Different
perspectives can be selected to customize this view. The Workload view shows the workloads
running under servers. Both views show current utilization metrics, allowing you to easily monitor
the operational status of the resources managed by Matrix OE.
With Matrix OE visualization, you can perform the following tasks:
• Customize the level of detail that you want to see

• Easily access additional Matrix OE capabilities to manage and configure systems and
workloads

• Inventory your virtual and physical servers

• Centrally configure your server resources for optimum utilization
Launch Matrix OE visualization from Systems Insight Manager in any of the following ways:
• From the top (HP SIM) menu bar, choose Tools→HP Matrix OE visualization...

• From the Systems and Event Collections list in the left navigation area, choose
Systems→Shared→Systems by Type→All VSE Resources, or expand the All VSE Resources
collection by clicking its icon, then choose a subset such as nPartitions

• Create a custom collection whose default view is set to “VSE”, and choose that collection in
the left navigation area

For more information about Matrix OE visualization, see Using Matrix Operating Environment.

HP Matrix OE logical server management
A logical server is a set of configuration information that you create, activate and move across
physical and virtual machines. It contains the logical server definition and description, including
the server compute resources (for example, number of CPU cores and amount of memory), and
the server connections to storage fabric and networks.
A logical server is managed within Matrix Operating Environment and, when activated, is applied
to the creation of a virtual machine using hypervisor-based software or to a bare-metal server blade
using HP Virtual Connect Enterprise Manager. Logical servers can be defined using the Create
Logical Server wizard or created and activated via the import of an existing server blade or virtual
machine.
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Logical server management allows you to perform tasks such as the following:
• Populate an enclosure

• Load-balance servers

• Evacuate servers, for routine maintenance or in case of disaster

NOTE: Logical server management is only supported on a CMS running Microsoft Windows.

For more information about managing logical servers, see the HP Matrix Operating Environment
Logical Server Management User Guide, available at http://www.hp.com/go/matrixoe/docs.

HP Capacity Advisor
Capacity Advisor lets you quickly and safely test proposed configuration changes in your data
center before you actually make them. To start Capacity Advisor, select Tools→Capacity Planning
from the top menu bar, or select the Planning tab on the Matrix OE visualization screen. With
Capacity Advisor, you can find answers to questions such as the following:
• Is there room on this system for an additional workload?

• Will this workload fit on this system?

• Can I consolidate these servers as virtual machines on a single server?

• What might my resource demand be in six months or a year?

• What are the estimated power costs for cooling a real or simulated system configuration?

• What does a comparison of several what-if scenarios reveal about the analyzed alternatives?
Capacity Advisor helps you optimize workloads across your management domain to help maximize
utilization of computing resources. It provides scenario analysis to help you manage your current
server resources and plan for changes to your workloads and computing environment (system CPU
and memory, network and disk I/O bandwidth, power use). These scenarios allow you to simulate
the following actions:
• Resizing or consolidating systems
• Resizing or consolidating workloads
• Moving workloads
Capacity Advisor provides the following additional features.
• Automated generation of reports

Capacity Advisor automates report generation, reducing the manual effort required to collect
data and present it for analysis.

• Trace-based simulator
Providing graphs over specified data intervals, Capacity Advisor gives a more complete and
accurate view of resource utilization than focusing on a single peak of activity.

• Ease of data gathering
Data is collected automatically using a secure protocol and stored in a central database for
analysis.

For more information about Capacity Advisor, see the HP Capacity Advisor User Guide, available
at http://www.hp.com/go/matrixoe/docs.

HP Capacity Advisor Consolidation software
Capacity Advisor is also available through a limited-duration license for systems that are intended
to be consolidated. The Capacity Advisor Consolidation software does not include Matrix OE
visualization or any other Matrix OE components. Using this software, you can collect and analyze
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data to help you plan the consolidation of existing systems, without requiring a full Matrix OE
license for those systems. For more information, see “Data collection and the HP Capacity Advisor
Consolidation software” in the HP Capacity Advisor User Guide.

HP Matrix Operating Environment infrastructure orchestration
Matrix infrastructure orchestration extends Matrix Operating Environment to provide rapid
provisioning and repurposing of infrastructure services from shared resource pools using a self-service
portal. Infrastructure orchestration delivers advanced template-driven design, provisioning and
on-going operations for multi-node, multi-tier infrastructure services.
Matrix infrastructure orchestration supports four main activities to automate the deployment of
infrastructure services:
Design An architect uses the graphical designer to create simple and complex infrastructure

templates that, when tested, can be published for users to create infrastructure
services.

Provision A self-service user selects an existing template and then requests infrastructure
provisioning from it, against an assigned pool of resources. The administrator can
approve or deny this request, and monitor its progress.

Operate The administrator manages server, network, and storage pools, defines virtual
machine images and software deployment jobs, performs manual provisioning
tasks as part of the fulfillment of self-service requests, and uses Insight Management
software to monitor the health and utilization of the managed environment.

Integrate Architects and administrators integrate infrastructure orchestration with existing IT
processes by modifying or creating HP Operations Orchestration workflows to
customize the infrastructure orchestration automation. They can link to approval
processes, extend operating system deployment and server configuration, and
integrate the SAN management processes with server deployment.

For more information about Matrix infrastructure orchestration and the related HP Operations
Orchestration software, see the list of documents under “Related information” (page 36).

HP Matrix Operating Environment recovery management
Matrix recovery management provides simplified disaster recovery of logical server environments.
With a mouse click, you can transfer application environments running on HP BladeSystems or on
virtual machines to a remote recovery site. It utilizes the data replication capabilities of HP storage
environments to ensure that application data is properly transitioned to the recovery location and
that the overall transition is measured in minutes, not days. Matrix recovery management is only
supported on an HP ProLiant CMS running Microsoft Windows.
Logical servers that are included in a recovery management configuration are referred to as
“DR-protected logical servers”. A recovery management configuration consists of two sites, each
managed by Matrix Operating Environment.
Matrix recovery management pairs symmetrically configured logical servers. One logical server
in the pair is activated at one site, while the other (the peer logical server) is deactivated at the
other site. The boot images of these DR-protected logical servers, including applications code and
data, reside on disk array volumes. The volumes used by active logical servers are replicated to
paired site.
If a disaster occurs at one site, the administrator at the paired site can trigger a site failover via a
push-button provided by Matrix recovery management. This prepares the storage associated with
the DR-protected logical servers at the paired site for read-write access, and then activates the
logical servers at the paired site.
For more information about Matrix recovery management, see the list of documents under “Related
information” (page 36).
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HP Storage Provisioning Manager
HP Storage Provisioning Manager (SPM) is a software tool that provides a service-centric
management interface to storage, allowing storage requests to be fulfilled with available storage
services from a storage catalog. It securely automates storage management tasks alongside the
Matrix OE visualization software. After storage policies and storage resources are input to the
storage catalog using the SPM user interface, you can use the Matrix OE logical server management
to request and have storage set up to meet server needs.
For more information, see the HP Storage Provisioning Manager (SPM) User Guide, available at
http://www.hp.com/go/matrixoe/docs.

Application Discovery
Application Discovery helps you identify and learn about the applications and processes running
in your data center or computing network.
With Application Discovery, you can do the following:
• Discover the location and number of recognized, running and installed applications in your

network or data center
• Monitor the activity and resource usage of running processes and applications

• Define and adapt application templates to your environment for better discovery of your
third-party and custom applications, and to make them available for adding to monitored
workloads

• Select the event types for which you want to receive notifications and set their level of
importance

For more information about Application Discovery, see the HP Application Discovery User Guide,
available at http://www.hp.com/go/matrixoe/docs.

HP Global Workload Manager (gWLM)
To access Global Workload Manager (gWLM) from the Matrix OE visualization screen, select the
Shared Resource Domain tab or select one of the items under Tools→Global Workload Manager
from the Matrix OE visualization menu bar. Global Workload Manager improves both workload
performance and resource utilization in a shared computing environment. For servers partitioned
with nPartitions, virtual partitions, virtual machines, psets, or FSS groups, Global Workload Manager
can do the following:
• Monitor each application.

• Determine the CPU resources needed by each application.

• Automatically migrate CPU resources between partitions to where they are needed most. This
migration improves application performance by making more resources available to the
application at times of peak demand. In addition, migrating idle resources to the applications
that are busy increases processor utilization.

For more information about Global Workload Manager, see the HP Global Workload Manager
User Guide, available at http://www.hp.com/go/matrixoe/docs.

HP Instant Capacity software
The Instant Capacity Manager is a web-based interface that can be used to monitor your Instant
Capacity environment. There are several screens available in Instant Capacity Manager, including
an overview of the Instant Capacity resources available, a Global Instant Capacity (GiCAP) group
manager screen to provide more insight into the group managers, and detail screens for GiCAP
groups and Instant Capacity complexes and hosts.
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You can get to Instant Capacity Manager in either of the following ways:
• From the Matrix OE Visualization tab, click the Instant Capacity technology link associated

with any managed system that has Instant Capacity components, TiCAP capacity, or is a
member of a GiCAP group.

• Select Tools→Instant Capacity Manager from the Matrix OE visualization menu bar.
For more information about Instant Capacity software, see the Instant Capacity Manager help.

Partition Manager
Partition Manager provides system administrators with a convenient graphical user interface to
configure and manage nPartitions on HP servers. Using Partition Manager, you can perform
configuration tasks without having to remember commands and parameters. You select nPartitions,
cells, I/O chassis or other components from the graphical display, then select an action from a
menu.
You can use Partition Manager to perform the following tasks:
• Create, modify and delete nPartitions

• Examine the nPartition configuration of a complex

• Check the complex for potential configuration and hardware problems

• Manage hardware resources on the complex
For more information about Partition Manager, see the Partition Manager help.

HP Integrity Virtual Machines Manager
Integrity Virtual Machines Manager is the GUI that you can use from your browser to manage
Integrity VM resources. Integrity Virtual Machines Manager allows you to create, configure and
evaluate virtual machines, and monitor and evaluate data and resources at the level of the VM
Host. You can view all of a VM Host's virtual machines and their assigned resources, and you can
view all resources assigned to a specific virtual machine or virtual switch. For example, Integrity
Virtual Machines Manager provides graphical views of virtual-to-physical network and storage
devices so that you can view I/O data, including resource utilization information. Integrity Virtual
Machines Manager obtains information about Integrity VM resources through Web-Based Enterprise
Management (WBEM) providers installed on the VM Host.
For more information about Integrity Virtual Machines Manager, see the HP Integrity Virtual Machines
Manager User Guide, available at http://www.hp.com/go/matrixoe/docs.

Product configurations
Different Matrix OE licenses are available for managing different types of systems, as shown in
the table below. The software is installed on a Central Management Server (CMS) running HP SIM,
which provides a browser-based user interface. A single CMS can be used to manage different
types of systems. The software is installed on the CMS once, regardless of how many or what types
of managed system licenses are purchased. Licenses for the managed systems are maintained on
the CMS.
For additional information about licensing, see “License management” (page 15).
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IMPORTANT: This table is a summary. Specific supported hardware and software configurations
are provided in the HP Insight Management Support Matrix , which is available at http://
www.hp.com/go/matrixoe/docs.

CMS platformManaged systems supportedLicense

HP Matrix Operating
Environment

• HP ProLiant server running Microsoft
Windows

• HP ProLiant servers running Microsoft
Windows or Linux

• •HP BladeSystem c-Class ProLiant server
blades running Microsoft Windows or
Linux

HP BladeSystem c-Class ProLiant
server blade running Microsoft
Windows

•• Virtual machine running under
VMware ESX or Microsoft Hyper-V

Virtual machines and VM hosts running
under VMware ESX, VMware ESXi, or
Microsoft Hyper-V on HP ProLiant hosts on HP ProLiant or selected non-HP

host
HP Matrix Operating
Environment for non-HP
servers

• Virtual machines and VM hosts running
under VMware ESX, VMware ESXi, or
Microsoft Hyper-V on selected non-HP hosts

• Selected non-HP servers running Microsoft
Windows or Linux

HP Matrix Operating
Environment for HP-UX

• HP ProLiant server running Microsoft
Windows

• HP Integrity servers running HP-UX,
Integrity Linux, or Microsoft Windows for
Integrity • HP BladeSystem c-Class ProLiant

server blade running Microsoft
Windows

• HP Integrity server blades running HP-UX,
Integrity Linux, or Microsoft Windows for
Integrity • Microsoft Windows virtual machine

running under VMware ESX or• nPartitions running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity Microsoft Hyper-V on HP ProLiant or

selected non-HP host• Virtual machines running under Integrity
Virtual Machines • HP Integrity server running HP-UX

• virtual partitions running under a vPars
monitor.

• HP Integrity server blade running
HP-UX

• HP-UX virtual machine running under
Integrity Virtual Machines

Features of Matrix Operating Environment
The specific features supported by Matrix Operating Environment depend on the type of CMS on
which the software is running.
• Table 1 (page 12) summarizes the features supported for different types of managed systems

using a CMS running Microsoft Windows.
• Table 2 (page 14) summarizes the features supported for different types of managed systems

using a CMS running HP-UX.
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Table 1 Matrix OE features on Windows CMS

Managed systems supportedFeature

Visualize and monitor physical and virtual resources and
workloads using Matrix OE visualization

• HP ProLiant servers running Microsoft Windows or Linux

• HP BladeSystem c-Class ProLiant server blades running
Microsoft Windows or Linux

• Virtual machines and VM Hosts running under VMware
ESX, VMware ESXi, or Microsoft Hyper-V on HP ProLiant
and supported non-HP servers

• Selected non-HP servers running Microsoft Windows or
Linux

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines

• Virtual partitions running under a vPars monitor.

Perform capacity analysis and planning using Capacity
Advisor

• HP ProLiant servers running Microsoft Windows or Linux

• HP BladeSystem c-Class ProLiant server blades running
Microsoft Windows or Linux

• Virtual machines and VM Hosts running under VMware
ESX, VMware ESXi, or Microsoft Hyper-V on HP ProLiant
and supported non-HP servers

• Selected non-HP servers running Microsoft Windows or
Linux

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines

• Virtual partitions running under a vPars monitor.

• Servers licensed for HP Capacity Advisor Consolidation
software

Visualize and monitor logical servers: server profiles that
can be easily created and freely moved

• HP BladeSystem c-Class ProLiant server blades running
Microsoft Windows1

• Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, or Microsoft Hyper-V on
HP ProLiant and supported non-HP servers

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity 1

• Virtual machines running under Integrity Virtual
Machines 2

Provision logical servers using HP Matrix Operating
Environment infrastructure orchestration

• HP BladeSystem c-Class ProLiant server blades running
Microsoft Windows1

• Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, or Microsoft Hyper-V on
HP ProLiant and supported non-HP servers

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity 1, 3

Enable site-to-site fault recovery of logical servers using HP
Matrix Operating Environment recovery management

• HP BladeSystem c-Class ProLiant server blades running
Microsoft Windows1
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Table 1 Matrix OE features on Windows CMS (continued)

Managed systems supportedFeature

Virtual machines running Microsoft Windows under
VMware ESX, VMware ESXi, or Microsoft Hyper-V on
HP ProLiant and supported non-HP servers

•

Identify and monitor running applications and processes
using Application Discovery

• HP Integrity servers running HP-UX or Integrity Linux

• HP Integrity server blades running HP-UX or Integrity
Linux

• Virtual machines running under Integrity Virtual
Machines

• Virtual partitions running under a vPars monitor.

Manage workloads with automated policies using Global
Workload Manager

• HP Integrity servers running HP-UX

• HP Integrity server blades running HP-UX

• Virtual machines running under Integrity Virtual
Machines

Manage HP Integrity virtual machines using Integrity Virtual
Machines Manager

• Virtual machines running under Integrity Virtual
Machines

• Integrity Virtual Machines VM Hosts

• HP Integrity cell-based servers and nPartitionsManage nPartitions and cell-based servers using Partition
Manager

• HP Integrity servers with HP Instant Capacity products
installed

Monitor HP Instant Capacity resources (iCAP, GiCAP, and
TiCAP) using Instant Capacity Manager

• HP Integrity servers with HP Serviceguard installedManage HP Serviceguard clusters using Serviceguard
Manager

1 Requires HP Virtual Connect Enterprise Manager on BladeSystem enclosure
2 Logical server operations on virtual machines under Integrity Virtual Machines are limited to: import, on-line guest migration

via logical server moves, power on/off, and unmanage.
3 Requires HP Matrix Operating Environment infrastructure orchestration for Integrity
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Table 2 Matrix OE Features on an HP-UX CMS

Managed systems supportedFeature

Visualize and monitor physical and virtual resources and
workloads using HP Matrix OE visualization

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines Manager

• Virtual partitions running under a vPars monitor

Perform capacity analysis and planning using HP Capacity
Advisor

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines Manager

• Virtual partitions running under a vPars monitor

Identify and monitor running applications and processes
using Application Discovery

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines Manager

• Virtual partitions running under a vPars monitor

Manage workloads with automated policies using HP
Global Workload Manager (gWLM)

• HP Integrity servers running HP-UX, Integrity Linux, or
Microsoft Windows for Integrity

• HP Integrity server blades running HP-UX, Integrity Linux,
or Microsoft Windows for Integrity

• Virtual machines running under Integrity Virtual
Machines Manager

• Virtual partitions running under a vPars monitor

Manage HP Integrity virtual machines using HP Integrity
Virtual Machines Manager

• Virtual machines running under Integrity Virtual
Machines Manager

• HP Integrity hosts running HP Integrity Virtual Machines

• HP Integrity cell-based servers and nPartitionsManage nPartitions and cell-based servers using Partition
Manager

• HP Integrity servers with HP Instant Capacity products
installed

Monitor HP Instant Capacity resources (iCAP, GiCAP, and
TiCAP) using HP Instant Capacity software

• HP Integrity servers with HP Serviceguard installedManage HP Serviceguard clusters using Serviceguard
Manager
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2 License management
This chapter describes the licensing model, the types of licenses available for Matrix Operating
Environment, and how to add and apply licenses. The tables in the following sections summarize
the hardware platforms and operating systems supported for each Matrix OE license. For detailed
hardware and software configurations supported by Matrix OE, see the HP Insight Management
Support Matrix , available at http://www.hp.com/go/insightmanagement/docs.

Matrix OE licensing model
Matrix OE is licensed for use on managed systems as shown in the following table. Licenses are
managed from the Central Management Server (CMS), using the Systems Insight Manager License
Manager database.

NOTE: Additional product licenses may be required, depending on your installation.

License requirement1System type

License per CPU socket or core2HP Integrity Server

License per CPU socket or core 2HP 9000 Server

License per systemHP ProLiant ML/DL/SL Server

No enclosure license required or available. Licenses apply
to individual server blades.

HP BladeSystem c-Class enclosure

License per bladeHP BladeSystem c-Class ProLiant server blade

License per CPU socket or core 2HP Integrity server blade

Covered by host server licenseVirtual machines running under any of the following:
• HP Integrity Virtual Machines

• VMware ESX

• VMware ESXi

• Microsoft Hyper-V

1 The HP Insight Capacity Advisor Consolidation software license is always licensed per system, regardless of system type.
See “HP Insight Capacity Advisor Consolidation software” (page 18).

2 Trial licenses are licensed per system. See “Trial licenses” (page 15).

To obtain a permanent License To Use (LTU) for Matrix OE, contact your HP sales representative,
your HP services representative, or your authorized HP reseller. The available licenses are listed
in the sections that follow.
To use a purchased license, it must be added to the Systems Insight Manager License Manager
database on the CMS and then applied to a managed system.

Trial licenses
The following trial licenses are available:

• When Matrix OE is installed on the CMS, 10 trial licenses for the HP Matrix Operating
Environment for HP-UX are included in the License Manager database. These licenses can be
applied to HP Integrity and HP 9000 systems. Each trial license is valid for 90 days after it is
applied to a managed system. To continue to manage these systems beyond the trial period,
permanent licenses must be purchased.
These trial licenses can be applied to managed systems by the Insight managed system setup
wizard or by the vselicense command. They cannot be applied through Systems Insight
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Manager License Manager. For information about the managed system setup wizard, see the
online help for the wizard. For information about vselicense, see the Command Reference.

• Trial licenses for the HP Matrix Operating Environment for 10 managed systems can be
obtained by registering with HP. To obtain these trial licenses, please contact your HP sales
representative, your HP services representative, or your authorized HP reseller.

You can view the status of your trial licenses using the Systems Insight Manager License Manager.
For information about License Manager, see Alternative Process: Use HP SIM License Manager.

End-user license agreement
Your use of Matrix OE is subject to the terms of the end-user license agreement included with the
software. Please read this document at its installed location on the CMS:
HP-UX CMS /opt/vse/src/README

Microsoft Windows CMS installation-directory\src\README

The default installation directory is C:\Program Files\HP\
Virtual Server Environment, but this directory can be
changed at installation time.

HP ProLiant servers and ProLiant server blades

Supported OSLicensed ProductsLicense Name

HP Matrix Operating
Environment

• Microsoft Windows• HP Matrix OE visualization

• •HP Capacity Advisor Linux

• HP Insight Control server migration

• HP Matrix Operating Environment
infrastructure orchestration

• HP Matrix Operating Environment
recovery management

Notes
• A license for HP Insight Control is also required. The Insight Control license includes HP Insight Control virtual

machine management, HP Insight Control server migration, HP Insight Control power management, and HP Integrated
Lights-Out.

• Logical server management is only supported on a CMS running Microsoft Windows.

• A license for HP Virtual Connect Enterprise Manager is required for BladeSystem enclosures in order to manage
logical servers on server blades.
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HP Integrity and HP 9000 servers and Integrity server blades

Supported OSLicensed ProductsLicense Name

• HP-UXHP Matrix Operating Environment
for HP-UX

• HP Matrix OE visualization

• HP Capacity Advisor

• HP Global Workload Manager (gWLM)

• HP Insight Control virtual machine
management

HP Matrix OE visualization • HP-UX• HP Matrix OE visualization

• •HP Insight Control virtual machine
management

Microsoft Windows for HP
Integrity

• Linux for HP Integrity

HP Capacity Advisor • HP-UX• HP Matrix OE visualization

• •HP Capacity Advisor Microsoft Windows for HP
Integrity• HP Insight Control virtual machine

management • Linux for HP Integrity

• HP-UXHP Global Workload Manager
(gWLM)

• HP Matrix OE visualization

• HP Global Workload Manager (gWLM)

• HP Insight Control virtual machine
management

Notes
• Logical server management is only supported on a CMS running Microsoft Windows.

• A license for HP Virtual Connect Enterprise Manager is required for BladeSystem enclosures in order to manage
logical servers on server blades.

• A license for HP Matrix Operating Environment infrastructure orchestration for Integrity is included with the HP-UX
VSE and DC operating environments.

• A license for Integrity iLO 2 Advanced is recommended in order to collect advanced power information for
visualization meters and capacity planning.

Non-HP servers

Supported OSLicensed ProductsLicense Name

Matrix Operating Environment
for non-HP servers

• Microsoft Windows• HP Matrix OE visualization

• •HP Capacity Advisor Linux

• HP Insight Control virtual machine
management

• HP Matrix Operating Environment
infrastructure orchestration

• HP Matrix Operating Environment recovery
management

Notes
• Logical server management is only supported on a CMS running Microsoft Windows.

• A license for HP Matrix Operating Environment recovery management is included, but recovery management is
not supported on non-HP servers in this release of Matrix OE.
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HP Insight Capacity Advisor Consolidation software
The HP Capacity Advisor Consolidation software license allows you to collect and analyze data
from systems that are planned to be consolidated. This license is only needed on managed systems
that do not have a license for Capacity Advisor or Matrix OE.

Supported PlatformsLicensed ProductsLicense Name

Servers running HP-UX 11i, Microsoft
Windows for Integrity, x86–based
Microsoft Windows Server, or Linux.

HP Capacity AdvisorHP Capacity Advisor Consolidation
software

Notes
• License is valid for six months after it is assigned to a system.

• Does not include license for Matrix OE visualization. Systems with only this license will not be visible in visualization.

Adding and applying licenses
To use a purchased license, you must first add it to the Systems Insight Manager License Manager
database on the CMS, then apply the license to a specific managed system. The CMS keeps track
of how many of each type of license are available to be applied to managed systems. As you
apply licenses, the number of available licenses decreases.

Recommended process: Use the managed system setup wizard
HP recommends using the Insight managed system setup wizard to add and apply licenses for
Matrix OE. To start the managed system setup wizard, select Configure→Managed System Setup
Wizard... from the top menu bar. Help is available in each step of the wizard. For more information
about the managed system setup wizard, see “Using the Insight managed system setup wizard”
(page 20), and the Insight Managed System Setup Wizard Getting Started Guide available from
http://www.hp.com/go/matrixoe/docs.

Alternative Process: Use HP SIM License Manager
If you choose not to use the Insight managed system setup wizard, you can use Systems Insight
Manager License Manager to add and apply most types of licenses. You can also use License
Manager to view the available and applied licenses for all products in the License Manager
database. To use the License Manager, you must have administrative rights on the CMS.
Some licenses cannot be applied through License Manager:
• Trial licenses can only be applied to managed systems by the Insight managed system setup

wizard or by the vselicense command. For information about vselicense, see “Command
reference” (page 41).

• LTUs from earlier versions of the VSE Management Software for Integrity or from the HP-UX
VSE or DC operating environments are managed using the vselicense command or the
“Scan for HP-UX Licenses” tool. For more information, see “Scan for HP-UX licenses ” (page 19).

Setting authorizations
To add and apply licenses, you must have administrative rights on the CMS, and you must be
authorized for the All Tools toolbox on the managed systems that you want to license. To assign
administrative rights to an HP SIM user, select the Users tab under Options→Security→Users and
Authorizations... and enable the “Configure CMS Security” option. To authorize users for toolboxes,
use the Authorizations tab under Options→Security→Users and Authorizations....
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Starting the License Manager
To start License Manager, select Deploy→License Manager... from the top menu bar. This menu
selection will only be available if you have administrative rights on the CMS. Online help is available
to guide you through the use of License Manager.
The License Manager lists all the available license types from which you can choose to deploy.

Order for applying licenses — Windows CMS managed systems
For systems that will be managed by a CMS running Microsoft Windows, applying licenses in the
proper order will simplify the process and reduce errors. From the Windows CMS, apply licenses
to each managed system in the order shown for each system type:
HP BladeSystem c-Class ProLiant
blades

HP iLO Advanced1.
2. VCEM (enclosure license required for logical server

management of server blades)
3. Insight Control
4. Matrix OE

HP ProLiant ML/DL/SL servers HP iLO Advanced1.
2. Insight Control
3. Matrix OE

HP BladeSystem c-Class Integrity
Blades

VCEM (enclosure license required for logical server
management of server blades)

1.

2. Matrix OE

Scan for HP-UX licenses
From a CMS, use the “Scan for HP-UX Licenses” task to perform the following functions:
• Enable the HP Matrix Operating Environment for HP-UX licenses that are included in the HP-UX

Operating Environments.
• Migrate unused licenses that were purchased for release 3.x or earlier of the VSE Management

Software to the HP SIM License Manager database and apply them to your managed systems
(if permitted by your licensing agreement with HP).

To launch this task from the License Manager, click Scan for HP-UX Licenses... on the last “Deploy:
HP Matrix OE for Integrity Licenses” screen. On the “Task Confirmation” screen, click Run Now.
Online help is available to guide you through the operation.
This task scans for licenses for any VSE Management Software for Integrity LTU that is installed on
the managed systems. It is not restricted to the type of license that was originally selected in License
Manager. It will only discover licenses on HP-UX systems, even if other types of systems were
included in the License Manager system selection. For more information about scanning for HP-UX
licenses and migrating unused licenses from earlier software versions, see vselicense(1M) (page 47).

License requirements for systems with HP Instant Capacity products
For systems using HP Instant Capacity products (including iCAP, GiCAP, and TiCAP), the total
number of licenses assigned across all nPartitions within the complex (or across multiple complexes
when using GiCAP) must be equal to or greater than the total number of processors that you have
purchased.

Using the CMS password reconfigure tool
The HP SIM field tools provide a command that enables you to quickly change passwords for a
large number of licensed systems at once. For information on the Systems Insight Manager field
tools and how to use them with the Matrix Operating Environment, see the HP Systems Insight
Manager User Guide at http://www.hp.com/go/insightmanagement/sim/docs.
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3 Getting Started
Installing the software

This document does not cover installation of the software or upgrade from previous versions of the
software. For installation and upgrade on a CMS running Microsoft Windows, see HP Insight
Management 7.0 Preinstallation Worksheet, HP Insight Management 7.0 Quick Installation Guide,
and HP Insight Management 7.0 Installation and Configuration Guide. For installation and upgrade
on a CMS running HP-UX, see HP Matrix Operating Environment for HP-UX 7.0 Installation and
Configuration Guide.

Configuring privilege elevation
Some Matrix OE management functions require privileged (root) access from the CMS to HP-UX,
Linux, and VMware ESX managed systems. Privilege elevation allows you to use your preferred
mechanism for acquiring root permissions as needed (for example, using sudo or PowerBroker),
without having to allow login through the root account.
Procedure 1 Configure privilege elevation for use with Matrix OE
1. Select Options→Security→Privilege Elevation... from the top menu.
2. Select Enable privilege elevation for Linux & HP-UX (or VMware ESX, according to the type

of managed system OS).
3. Select the elevation tool type from the menu.

IMPORTANT: Matrix OE does not support the option A password is required for this privilege
elevation tool. Make sure this option is not checked.

4. Select use this user and enter a user name that will be used to access all managed systems
with this type of operating system. You will need to enable the selected user login on the
managed systems.

Additional configuration might also be needed. For example, you might need to configure SSH
access using Configure→Configure or Repair Agents..., and you might need to configure the
managed system to allow host authentication for non-root users. For more information, see the HP
Systems Insight Manager Help, mxagentconfig(1M), and the Insight Management and Matrix OE
installation and configuration guides. Links to these documents can be found in “Related information”
(page 36).

Using the Insight managed system setup wizard
Insight managed system setup wizard configures systems to enable them to be managed by Systems
Insight Manager and its plug-in applications, including Matrix Operating Environment. Use the
managed system setup wizard for initial configuration or re-configuration of any selected set of
systems. After you specify which management features you want to use on the selected systems,
the wizard will analyze the current configuration of each system and perform the following functions:
• Install any agents necessary to enable the selected management features

• Apply any required licenses from the set of licenses available in the License Manager database

• Complete additional configuration steps required by the features that you selected
After initial configuration, you can run the managed system setup wizard again at any time to
modify the selected management features and change the configuration.
For more information about the managed system setup wizard, see the HP Insight Managed System
Setup Wizard Getting Started Guide, available at http://www.hp.com/go/matrixoe/docs
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Configuring user authorizations
Users must be authorized in Systems Insight Manager to use Matrix OE tools and features.
Information about Matrix OE user authorizations is available in the Matrix Operating Environment
online help, with additional information provided in the help of Matrix OE components where
needed.

Configuring data collection credentials
Systems that are to be managed using Matrix Operating Environment or simulated for capacity
planning must be configured to allow data collection from the CMS. In general, data collection
can be enabled either through the Utilization Provider (UP) installed on the managed system, or
through native data collection. For a description of the two methods, see the section “Comparison
of agentless and UP data collection” in the HP Capacity Advisor User Guide.
Authentication is required to enable data collection. The required credentials are summarized in
Table 3 (page 21). You can verify or modify the WBEM or SSH credentials for a system that has
been discovered in Systems Insight Manager by selecting Options→Security→Credentials→System
Credentials... from the top menu bar.

Table 3 Data collection credentials requirements

Required access levelRequired access credentials
Managed system OS / Data Collection
Method

Non-root or rootWBEM credentials must be configured
(or discovered) in HP SIM for these
systems

HP-UX/Utilization Provider

Does not require Administrator level
access

WBEM credentials must be configured
(and discovered or identified) in HP
SIM for these systems

Integrity Windows, (physical server or
VM), from an HP-UX CMS/Utilization
Provider

WBEM login must be a member of the
Administrators group on these systems

WBEM credentials must be configured
(or discovered) in HP SIM for these
systems

Windows physical server from a
Windows CMS/Agentless

Non-root or root credentials, or
certificate-based authentication may be
used

SSH credentials or certificate-based
SSH authentication must be configured
(or discovered) in HP SIM for these
systems

x86 Linux physical server or Integrity
Linux (physical server or
VM)/Agentless

NOTE: On a Windows CMS, any VMware ESX and Microsoft Hyper-V hosts must be properly
registered in HP Insight Control virtual machine management to allow data collection from these
hosts and their virtual machines. For information about registering the hosts in Insight Control virtual
machine management, see HP Insight Control Virtual Machine Management User Guide.

About the HP Capacity Advisor Data Collection Service
With 7.0 release, collection of resource usage data is managed by a service, rather than by a
scheduled task in the CMS. The service gathers data provided by the Utilization Provider and
native data collectors and normalizes it into 5–minute data points. The service starts automatically
on installation and runs constantly unless stopped — providing data for visualization of resource
usage on discovered systems and workloads and for capacity planning. When needed, the service
can be stopped or restarted on the CMS.
Procedure 2 Windows CMS: Stopping the HP Capacity Advisor Data Collection Service
1. Select Start→Administrative Tools→Services.
2. In the Name column, look for “HP Capacity Advisor Data Service”. Right-click on this name

and select Stop from the menu.
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Procedure 3 Windows CMS: Starting the HP Capacity Advisor Data Collection Service
1. Select Start→Administrative Tools→Services.
2. In the Name column, look for “HP Capacity Advisor Data Service”. Right-click on this name

and select Start from the menu.
Procedure 4 HP-UX CMS: Stopping the HP Capacity Advisor Data Collection Service
• From the command line as root, run /sbin/init.d/hp_cpdata_service stop

Procedure 5 HP-UX CMS: Starting the HP Capacity Advisor Data Collection Service
• From the command line as root, run /sbin/init.d/hp_cpdata_service start

NOTE: The Options→Data Collection menu option (on the top menu bar) allows you to configure
data collection for server inventory only. See “Solving utilization data collection problems” (page 22)
when you suspect resource utilization data is missing or utilization data collection is not working.

Configuring data metrics to better reflect your environment
Capacity Advisor provides tools for making the data metrics displayed in the visualization profile
viewer and in capacity planning scenarios better reflect your computing environment.

• From the Matrix OE Visualization tab or the Planning tab, select Configure→Global Utilization
Limits to set default limits for utilization of CPU, memory, and disk and network I/O bandwidth
to better reflect your Service Level Agreement.

• Determine your expected growth rate, then use Configure→Global Forecast... to realistically
project future utilization.

• Reflect your business cycle(s) by changing the displayed date range in your scenarios and
observing the peak, sustained, 90th percentile, and average data views.

• On the Visualization tab, use Configure→Calibrate Power (All Selected Systems)... to define
power settings for your systems. You must have full authorization on the managed nodes to
use this function.

Solving utilization data collection problems
Matrix Operating Environment provides a default Events collection called “Utilization Data Collection
Events”.

When you suspect you are experiencing a utilization data collection error, review the event listings
available from this menu. To obtain details about an event, including how to address a problem,
click the event type to open the detail table.
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To learn more about how to use event collections, click the button to read “Navigating the
event table view page” in the HP Systems Insight Manager Help.
To learn more about Capacity Advisor functions, see the HP Capacity Advisor User Guide.

Removing unneeded agent software
If you have upgraded from a previous installation of Insight Dynamics software or the VSE
Management Software, there may be agents installed on some of your managed systems that are
no longer needed. This will occur on managed systems that previously used the Utilization Provider
for data collection and are now configured for agentless or native data collection. The following
types of systems are affected:
• Integrity Linux or x86 Linux managed systems. In releases prior to version 6.0, these systems

needed the Utilization Provider for data collection. In the current release, these systems will
be configured to use agentless data collection. The Utilization Provider is not supported by
Matrix Operating Environment on Linux managed systems.

• Microsoft Windows managed systems, but only if you are using a CMS that is also running
Microsoft Windows (agentless data collection from Windows systems is not supported on an
HP-UX CMS).

In these cases, when you use the Insight managed system setup wizard to configure the system,
the following message will be displayed:
  Agentless data collection is not configured; it will be configured.
  An HP Utilization Provider has been detected; it will not be used
  for data collection.
  You should remove any sub-OS workloads defined on this system.

NOTE:
Any Windows sub-OS workloads on previous versions where this configuration was supported are
automatically removed during the upgrade to HP Matrix Operating Environment 7.0.

You may choose to remove the Utilization Provider from the affected systems after they have been
configured for agentless data collection.

IMPORTANT: Even though Matrix OE will no longer use the Utilization Provider for data collection,
there may be other software installed on the system that still uses it (for example, HP Insight Control
power management). Do not remove the agent if it is still in use.

Procedure 6 Remove the Utilization Provider from a Windows 2003 system
1. From Control Panel, select Add or Remove Programs.
2. Select “HP WMI Util Provider v1.8.1.1” (or the current installed version).
3. Click Remove.
Procedure 7 Remove the Utilization Provider from a Windows 2008 system
1. From Control Panel, select Program and Features.
2. Select “HP WMI Util Provider v1.8.1.1” (or the current installed version).
3. Click Uninstall.
Procedure 8 Remove the Utilization Provider from a Linux system
1. Open a command shell with root privileges.
2. Execute the following command:

rpm -e hp-utilprovider

For more information about agentless data collection, see the section “Comparison of agentless
and UP data collection” in the HP Capacity Advisor User Guide.
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Using Matrix OE visualization
Matrix OE visualization provides features that let you visualize and manage physical and virtual
servers discovered and licensed for use within the Matrix Operating Environment. Using
visualization, you can:
• customize the level of detail that you want to see
• easily access additional applications to manage and configure systems and workloads
• centrally configure your server resources for optimum utilization
• manage logical servers

Start Matrix OE visualization From HP SIM
Start HP Matrix OE visualization software from HP Systems Insight Manager in any of the following
ways:
• From the blue HP SIM menu bar, choose Tools→HP Matrix OE visualization...:

The first time you start Matrix OE visualization, the Visualization View appears with the default
Physical and Virtual perspective. This perspective shows all physical and virtual systems in
graphical compartments.
When you start Matrix OE visualization subsequent times, the software checks to see if you
had previously set a default view by modifying the user preferences. If you set a collection
(for example, Blade), Matrix OE visualization displays that collection.
If you create a custom collection and set the custom collection to the default collection, and
you later delete that collection and start Matrix OE visualization using the Tools→Matrix OE
visualization menu selection, a blank screen is displayed if you start Matrix OE visualization
quickly (within a minute or two of deleting the collection). If you wait a minute or so, the default
collection is reset to All VSE Resources. Alternatively, you can enter Matrix OE visualization
through the left side menu and change your preference to an existing collection.

• From the HP Systems Insight Manager Systems and Event Collections list in the left-hand
navigation area, choose Systems→Shared→Systems by Type→All VSE Resources.
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• From the Systems Insight Manager System and Event Collections list in the left-hand navigation
area, expand the All VSE Resources collection by clicking its icon, then choose a subset
such as nPartitions.

• Create a custom Systems Insight Manager collection whose default view is set to “VSE”. Select
this collection to start Matrix OE visualization. This is described in more detail in Customizing
Systems Insight Manager Collections and Home Page. That section also describes how to
customize Systems Insight Manager to display Matrix OE visualization automatically as soon
as Systems Insight Manager starts.

When you start the Matrix OE visualization from any of the methods listed above, a splash screen
displays as the Matrix OE visualization loads.

NOTE: Do not create multiple browser windows in the same session by using Ctrl-N or File→New
Window in Internet Explorer 7 or Firefox. This results in the same session running in both windows
and causes errors in the Matrix OE visualization. Similarly, do not create multiple tabs by using
Ctrl-T orFile→New Tab, which also causes problems. You can, however, start multiple browsers
from the desktop icon or the Start button. In this case, a different session can run in each browser,
which will not cause Matrix OE visualization problems.

Matrix OE tabs
Matrix Operating Environment provides four tabs to move among the capabilities offered by Matrix
OE visualization, Capacity Advisor, and Global Workload Manager:
• Visualization tab – View a visual representation of all managed servers, their relationships to

each other or to an enclosure, and resource usage data for each server. You can easily
navigate to the management application for each server technology. For more information,
see the online help accessible from the Visualization tab.

• Workload tab – View workloads in association with their servers and their utilization settings,
within a compact table format. See the online help accessible from the Workload tab.

• Shared Resource Domain tab – View and manage Shared Resource Domains (SRDs) using HP
Global Workload Manager (gWLM). gWLM allows you to centrally define resource-sharing
policies that you can use across multiple HP servers. For more information, see the online help
accessible from the Shared Resource Domain tab and see the HP Global Workload Manager
User Guide.

• Planning tab – View computing resource utilization data and create usage scenarios using
Capacity Advisor. For more information, see the online help accessible from the Planning tab
and see the HP Capacity Advisor User Guide.

Matrix OE menu bar
The Matrix OE menu bar provides convenient access to the Matrix OE tools and actions after
clicking a Matrix OE tab for a given application.
To perform an action on a system or compartment, select its checkbox, then choose the menu
selection from the Matrix OE menu bar. Some menu selections (such as Create→Workload
Definition...) do not require you to select a system first.
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NOTE: Menu selections vary between the Matrix OE visualization tabs (Visualization tab and
Workload tab) and the tabs that take you outside the Matrix OE visualization (i.e., the Shared
Resource Domain tab and Planning tab). The page title indicates the management application for
the selected tab, for example, Matrix OE visualization or Planning.
Menu selections are disabled if any of the following circumstances exist:
• A required selection has not been made. For example, Modify→Workload Definition... is

enabled only after you select a workload.
• Ambiguous selections have been made. For example, if you select more than one workload,

Modify→Workload Definition... is not enabled.
Be sure to select the checkbox to select the appropriate system or systems before choosing a menu
selection from the Matrix OE menu bar.

The following menu options are available from the Matrix OE menu bar. See the online help for
each menu selection to learn more.

Table 4 Matrix OE visualization Tools menu

DescriptionMenu selection

Use the Global Workload Manager task screens to define
resource-sharing policies across multiple HP servers.

Global Workload Manager
→ Getting Started – gWLM Home...
→ Manage Systems and Workloads...
→ Edit gWLM Policies...
→ gWLM Real-time Reports...
→ gWLM Historical Reports...
→ gWLM Advanced Reports...
→ Events...

Use the Virtual Connect Enterprise Manager task screens to
manage Virtual Connect domains.

Virtual Connect Enterprise Manager VCEM)
→ VCEM Homepage...
→ Add Virtual Connect Domain to Group...
→ Remove Virtual Connect Domain from Group...
→ Virtual Connect Domain Properties..
→ Virtual Connect Domain Group Properties..

Open profile viewers for visualized systems or to create a
capacity planning scenario using Capacity Advisor.

Capacity Planning
→ View Planning Scenarios...
→ View Capacity Advisor Data...

Manage logical servers in virtualized environments. Logical
server actions are available from a Windows CMS only.

Logical Servers
→ Activate...
→ Copy...
→ Import...
→ Deactivate...
→ Move...
→ Power
→ Refresh...

Provide disaster recovery protection for logical servers configured
and managed by Matrix OE visualization.

HP Matrix OE recovery management...

Deploy, manage and monitor the overall behavior of Matrix
infrastructure orchestration and its users, templates, services,

HP Matrix OE infrastructure management

resources, and organizations. Infrastructure orchestration is
available on Windows CMS only.
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Table 4 Matrix OE visualization Tools menu (continued)

DescriptionMenu selection

Control the amount of computing resources that processes use
during peak system load. Process Resource Manager is available
on HP-UX only.

Process Resource Manager
→ Monitor PRM Groups
→ Configure PRM Groups

Replace all of the monitored workload definitions on the selected
managed system.

Update System Workloads

Table 5 Matrix OE visualization Create menu

DescriptionMenu selection

Managed systems and workloads defined to be part of a shared resource
domain.

Shared Resource Domain...

Create a monitored workload.Workload Definition...

Create a logical server (Windows CMS only).Logical Server...

Create a capacity planning scenario.Planning Scenario...

Table 6 Matrix OE visualization Modify menu

DescriptionMenu selection

Modify the definition of a shared resource domain.Shared Resource Domain...

Edit properties of a monitored workload.Workload Definition...

Edit properties of a logical server (Windows CMS only).Logical Server

Edit storage pools for use by logical servers (Windows CMS only).Logical Server Storage Pools...

Edit properties of portability groups (Windows CMS only).Logical Server Portability Groups...

Edit target attributes associated with logical servers (Windows CMS
only).

Logical Server Target Attributes...

Table 7 Matrix OE visualization Delete menu

DescriptionMenu selection

Remove an SRD definition from the configuration.Shared Resource Domain

Remove an existing workload definition. You will be prompted to confirm the
deletion.

Workload Definition(s)...

Remove a logical server (Windows CMS only).Delete Logical Server...

Stop managing a logical server (Windows CMS only).Unmanage Logical Server...

Table 8 Matrix OE visualization Configure menu

DescriptionMenu selection

Modify parameters in the Capacity Advisor forecast model,
which are applied as the default in resource use trend displays
in the profile viewer.

Global Forecast...

Modify utilization limits for CPU and memory use, which are
applied by default to data in resource use displays and data
tables in the profile viewer.

Global Utilization Limits...

Define a forecast model for workloads.Workload Forecast...

Define utilization limits for workloads.Workload Utilization Limits...
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Table 8 Matrix OE visualization Configure menu (continued)

DescriptionMenu selection

Calibrate power for selected systems managed by Matrix OE.Calibrate Power (All Selected Systems)...

Set desired capacity for network and disk I/O bandwidth for
selected systems.Edit Network and Disk I/O Capacity...

View systems with agentless data collection or use advanced
options .

Agentless Data Collection...
→ List Agentless Systems
→ Advanced Agentless Options

Modify some aspects of Matrix Operating Environment for
personal use.

User Preferences

The following table lists menu selections that you can use to manage policies defined in Global
Workload Manager.

Table 9 Matrix OE visualization Policy menu

Menu selection

Apply gWLM Policy...

Change Associated gWLM Policy...

Edit gWLM Policies...

Remove Associated gWLM Policy...

Create gWLM Policy...

Table 10 Report Menu

DescriptionMenu Selection

Monitor current interaction of workload activity and management
policies.

gWLM Real-time Reports...

Create a report of historical workload activity.gWLM Historical Reports

Create a report showing overall workload activity and to help
identify workloads that require more resources.

gWLM Advanced Reports...

Create a report showing computing resource usage (CPU,
memory, network I/O, disk I/O, power) and trends in usage.

Utilization Report...

Create a report showing job status and messages for logical
servers (Windows CMS only).

Logical Server Job Status...

Create a report that provides additional information for logical
servers (Windows CMS only).

View Logical Server Details...

Matrix OE tool bar
The Matrix OE visualization tool bar provides a convenient way to adjust the display of compartment
information. Figure 1 shows the Matrix OE visualization toolbar options.
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Figure 1 Matrix OE visualization tool bar options

1 The drop-down menu allows you to select different ways of visualizing your enterprise. The
default view is the “Physical and Virtual” view, which shows all physical and virtual servers
and the greatest number of nodes. You can select alternate views for server blades, logical
servers, ServiceGuard clusters, or virtual machines; or show systems and events. In most cases,
selecting an alternate view limits the number of nodes displayed by restricting the view to a
particular type of node (“Virtual Machine”, for example). You can change the default view
that appears when you access Matrix OE visualization by modifying your user preferences.
For more information, see the online help for user preferences.

2 Select the Show Workloads check box or Show Workloads button to the left of the check box
to display sub-OS workloads running on a given system. Workload compartments display,
when they exist. Click either tool bar element to clear the workloads from the display.
In the following figure, a workload running on an Integrity VM host is shown in the blue
sub-compartment. By default, this control is turned off; Matrix OE visualization initially filters
out workload information from the compartment. For more information, see the online help
for compartment details.

3 The tool bar expand and collapse buttons allow you to manage the extent of detail you want
shown in the compartments and sub-compartments. For information about how these buttons
work, see the online help for tool bar buttons.

4 The Search field allows you to locate a given system by searching for a compartment name.
When you enter the name in the search field, Matrix OE visualization first highlights all
complete or partial matches of the name. When you click the Search button or press Enter,
Matrix OE visualization moves the scroll bar to the first compartment name it matches. For
example, searching for the system citrine moves the scroll bar so the compartment for that
system is at the top:

For more information, see the online help for the tool bar search feature.
5 The Refresh button allows you to update the display to include the latest compartments,

their relationships, and utilization information. Normally, refreshing the display is not necessary
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because the view is updated automatically as new data becomes available. However, you
might use the Refresh button to reattempt gathering utilization data for all items to ensure the
view is showing the latest information. Refreshing the view updates all containers and
relationships, resource utilization data, authentication credentials (WBEM) from HP Systems
Insight Manager, and workload information from Global Workload Manager. While the view
refreshes, the Refresh button spins to indicate it is in progress.

6 Status errors or warnings when receiving data are indicated by an alert button. For example,
a warning will appear if a system lacks a valid license or if a license has expired. Multiple
alerts are indicated by the number displayed. Click the alert button to view detailed information
about the error(s) or warning(s). An alert popup displays. Click the [X] button in the upper
right-hand corner of the popup to close it.

For more information, see the online help for alerts.

Customizing collections and home page
The following sections describe ways to customize Systems Insight Manager to make it more
convenient to start Matrix OE visualization and view the systems that you most frequently manage.

Creating custom collections
In Systems Insight Manager, you can create custom system collections whose default view is set to
any of the following options:
• VSE – Makes the Matrix OE visualization the default view for the collection and opens with

the “Physical and Virtual” perspective.
• gWLM – Makes the Shared Resource Domain tab the default view for the collection.

• VSE (Logical Servers) – Makes Matrix OE visualization the default view for the collection
and opens with the “Logical Server” perspective.

• VSE (Blades) – Makes Matrix OE visualization the default view for the collection and opens
with the “Blades” perspective.

• VSE (Virtual Machines) – Makes Matrix OE visualization the default view for the
collection and opens with “Virtual Machines” perspective.

• VSE (Serviceguard) – Makes Matrix OE visualization the default view for the collection
and opens with the “Serviceguard” perspective.

• VSE (collection nodes only) – Makes Matrix OE visualization the default view and
opens with “Physical and Virtual” perspective, but only showing nodes that are in that collection
and that you explicitly have authorizations to view.

NOTE: Other VSE views might pull in authorized parent or child nodes not explicitly defined
in a collection.

Selecting a custom collection starts Matrix OE visualization. Using a custom collection instead of
All VSE Resources can provide significant performance improvements because only the systems in
your custom collection will be displayed.
To create a custom collection, use the following procedure:
1. From the Systems and Event Collections list in the left-hand navigation area, select the

Customize... link.
2. Click New... to create a new custom collection.
3. Use the radio button to choose whether to individually specify the systems in the collection or

select systems based on their attributes.
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4. Specify the systems or the attributes of systems to be included in the collection and click Save
As Collection.

5. Specify the collection name and its location in the Systems tree, then click OK.

NOTE: Non-administrators can only save collections under the Private collection, whereas
administrators can save them anywhere. Any collections intended for use with the default
collection preference must be saved directly under the All VSE Resources collection.

6. Select the radio button next to the newly created collection and click Set Properties.
7. Change the Default View to VSE, gWLM , VSE (Logical Servers), VSE (Blades),

VSE (Virtual Machines), VSE (Serviceguard), or VSE (Collection Nodes
Only), and then click OK.

For more information on Visualization views or perspectives, see the online help for Matrix OE
visualization.

Automatically displaying Matrix OE visualization
You can customize Systems Insight Manager so that your preferred perspective in Matrix OE
visualization is automatically displayed as soon as Systems Insight Manager starts.
Use the following procedure to set your Systems Insight Manager home page.
1. From the top menu bar, choose Options→Home Page Settings...
2. Select the option This collection and choose All VSE Resources or another collection from the

menu.
3. Click OK.
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4 Troubleshooting
This chapter describes some of the tools and procedures that can be used to troubleshoot problems
in Matrix Operating Environment. Additional troubleshooting information can be found in the user
guides listed in “Using Matrix OE” (page 37). For information about known issues and workarounds
in this release, see the HP Matrix Operating Environment 7.0 Release Notes.

Memory and other system requirements
Make sure that your CMS and managed systems meet the requirements specified in the HP Insight
Management 7.0 Support Matrix. In particular, note the recommended and minimum supported
memory requirements. This document is available at http://www.hp.com/go/matrixoe/docs .
If error messages about exceeding heap space are displayed, you may need to increase the heap
size of the Systems Insight Manager Java Virtual Machine (JVM). On 64–bit systems, Systems
Insight Manager sets the heap size to 4096MB (4GB). You can specify a different heap size by
setting the JVMMAXHEAP value (in MB) in the globalsettings.props file. On HP-UX, this file
is at /etc/opt/mx/config/globalsettings.props. On Windows, it is at
installation-directory\config\globalsettings.props. The default installation
directory is C:\Program Files\HP\Virtual Server Environment, but this directory can
be changed at installation time.

Insight managed system setup wizard
Many configuration issues can be avoided by using the managed system setup wizard to configure
managed systems for use with Matrix OE. The wizard automates the installation of required licenses,
agent software, and other configuration settings to support the management capabilities intended
for use on the system.
To start the managed system setup wizard, select Configure→Managed System Setup Wizard...
from the top menu. Help is available in each step of the wizard.

Diagnose menu actions
There are three tasks available from the Diagnose→Troubleshoot Matrix Operating Environment
menu, described in the following sections. These tasks use the vseassist command to perform
configuration checks. For examples of the output from these checks, see vseassist(1M) (page 42).

Check CMS configuration
This task performs a number of configuration checks on the CMS. When troubleshooting your
configuration, perform this task first. Once you have resolved any CMS configuration issues, you
can diagnose issues with specific managed systems using the “Check CMS to managed node
communication” (page 33) and “Check managed node configuration” (page 34) tasks described
below.
Procedure 9 Check the configuration of your CMS
1. From the top menu bar, select Diagnose→Troubleshoot Matrix Operating Environment→Check

CMS Configuration....
2. To schedule this task to run periodically or at a set time, click Schedule. The Schedule Task

screen is displayed. Help on scheduling options is available from that screen. After the task
executes, you can view the results by selecting Tasks & Logs→View Task Results... from the
top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on the
CMS and displays the results in the Stdout tab.
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3. For each check performed by this task, one of the following status indicators is displayed:

No configuration problem was foundPASS

A serious configuration problem was found. You must resolve the problem for correct
operation of Matrix Operating Environment.

FAIL

A configuration problem was found. The problem will not necessarily prevent correct
operation of Matrix Operating Environment, but it may limit or restrict operation of some
features.

WARN

Not Applicable: the check does not apply to this type of system.N/A

4. Optional: To print a copy of the output, click View Printable Report, then click Print.
This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on an
HP-UX CMS, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.

TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.

You can review these results again later by selecting Tasks & Logs→View Task Results... from the
top menu bar.

Check CMS to managed node communication
This task checks the communication between the CMS and selected managed systems. When
troubleshooting your Matrix OE configuration, perform the “Check CMS configuration” (page 32)
task first, to make sure that you do not have any unresolved CMS configuration issues. Then use
this task to resolve communication issues with managed systems where you are having problems.
Some of the problems detected with this option include expired licenses, no open WBEM ports,
and improperly configured SSH authentication. These checks will verify whether the CMS can
communicate with the managed systems in order to perform management functions.
Procedure 10 Check the communication between the CMS and managed systems
1. Optional: Select the managed systems where you are having problems. You can select systems

by checking the selection box next to each system name in the Visualization View . If you
prefer, you can start this task with no systems selected. In that case, you are prompted to select
the systems from the available HP SIM system collections after the next step below.

2. Select Diagnose→Troubleshoot Insight Dynamics→Check CMS to Managed Node
Communication... from the top menu bar.

3. Optional: If no systems have been selected yet, you are prompted to select from the available
HP SIM system collections. If you have already selected systems, then those systems are
displayed in the Verify targets screen. Systems Insight Manager provides several options for
adding or removing systems on this screen. For help, select Help→For HP Systems Insight
Manager from the top menu bar, then select the “Operations” topic and the “Managing with
tasks” subtopic.

4. To schedule this task to run periodically or at a set time, click Schedule. The Schedule Task
screen is displayed. Help on scheduling options is available from that screen. After the task
executes, you can view the results by selecting Tasks & Logs→View Task Results... from the
top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on the
CMS and displays the results in the Stdout tab.
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5. For each check performed by this task, one of the following status indicators is displayed:

No configuration problem was foundPASS

A serious configuration problem was found. You must resolve the problem for correct
operation of Matrix OE.

FAIL

A configuration problem was found. The problem will not necessarily prevent correct
operation of Matrix OE, but it may limit or restrict operation of some features.

WARN

Not Applicable: the check does not apply to this type of system.N/A

6. Optional: To print a copy of the output, click View Printable Report, then click Print.
This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on
HP-UX systems, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.

TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.

You can review these results again later by selecting Tasks & Logs→View Task Results... from the
top menu bar.

Check managed node configuration
This task checks the configuration of HP-UX, Microsoft Windows or Linux managed systems by
using mxexec to copy the vseassist command to selected managed systems, and remotely
execute it there. When troubleshooting your Matrix OE configuration, perform the “Check CMS
configuration” (page 32) task first, to make sure that you do not have any unresolved CMS
configuration issues. Then use the “Check CMS to managed node communication” (page 33) task
to resolve communication issues with managed systems where you are having problems. Once
you have resolved the communication issues, use this task to resolve configuration issues for any
managed systems where you are still having problems.
Procedure 11 Check the configuration of managed systems
1. Optional: Select the managed systems where you are having problems. You can select systems

by checking the selection box next to each system name in the Visualization View. If you
prefer, you can start this task with no systems selected. In that case, you are prompted to select
the systems from the available HP SIM system collections after the next step below.

2. Select Diagnose→Troubleshoot Insight Dynamics→Check Managed Node Configuration...
from the top menu bar.

3. Optional: If no systems have been selected yet, you are prompted to select from the available
HP SIM system collections. If you already selected systems, then those systems are displayed
in the Verify targets screen. Systems Insight Manager provides several options for adding or
removing systems on this screen. For help, select Help→For HP Systems Insight Manager from
the top menu bar, then select the Managing with tasks topic.

4. To schedule this task to run periodically or at a set time, click Schedule. The Schedule Task
screen is displayed. Help on scheduling options is available from that screen. After the task
executes, you can view the results by selecting Tasks & Logs→View Task Results... from the
top menu bar.
To run this task immediately, click Run Now. This executes the vseassist command on the
CMS and displays the results in the Stdout tab.

34 Troubleshooting



5. For each check performed by this task, one of the following status indicators is displayed:

No configuration problem was foundPASS

A serious configuration problem was found. You must resolve the problem for correct
operation of Matrix OE.

FAIL

A configuration problem was found. The problem will not necessarily prevent correct
operation of Matrix OE, but it may limit or restrict operation of some features.

WARN

Not Applicable: the check does not apply to this type of system.N/A

6. Optional: To print a copy of the output, click View Printable Report, then click Print.
This task writes detailed information to the log file (/var/adm/syslog/vseassist.log on
HP-UX systems, installation-directory\logs\vseassist.log on Microsoft Windows
systems). Check the log file for details of any problems encountered.

TIP: The vseassist command line that was executed by this task is displayed on this screen
above the output box. This command is also displayed in the printable version of the report. You
can use this information to create your own diagnostic scripts that can be run from the command
line.

You can review these results again later by selecting Tasks & Logs→View Task Results... from the
top menu bar.

vseassist command
The vseassist command, which implements the Diagnose menu actions described in the previous
section, can also be executed directly from the command line on the CMS. If you are unable to
resolve communication issues with one of your managed systems, you can install or copy this
command to the managed system and run it from the command line there.
For details of the command line options, suggested diagnostic procedure, and examples, see
vseassist(1M) (page 42). On an HP-UX CMS, this reference page can also be viewed from the
command line using the man command.
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5 Support and other resources
Contacting HP

To obtain product support, contact your HP Support Representative, your HP Services Representative,
or your authorized HP reseller. For more information about support services, visit http://
www.hp.com/go/support.
To send comments and suggestions regarding the documentation for Matrix OE, use the following
e-mail address: docsfeedback@hp.com.
HP does not provide product support through the documentation feedback e-mail address.
For other ways to contact HP, visit http://www.hp.com/go/assistance.

Related information
For information about open-source products included with Matrix Operating Environment (including
license constraints, updates, and security information), see the end-user license agreement included
with HP Matrix Operating Environment. This document is installed on the CMS at the following
locations:
HP-UX CMS /opt/vse/src/README

Microsoft Windows CMS installation-directory\src\README

The default installation directory is C:\Program Files\HP\
Virtual Server Environment, but this directory can be
changed at installation time.

Manuals and white papers
The latest versions of manuals and white papers for Matrix OE and related products can be
downloaded from the HP Web. The manuals and white papers listed below can all be found at
the Matrix OE information library (http://www.hp.com/go/matrixoe/docs).
The following tables list the manuals and white papers available at this site. Some documents
appear in multiple tables.
Installation and configuration: Microsoft Windows CMS
Installation and configuration: HP-UX CMS
Using Matrix OE

Installation and configuration: Microsoft Windows CMS

DocumentTopic

• HP Insight Management Support MatrixRequirements, feature support,
compatibility

Release notes • HP Matrix Operating Environment Release Notes

• HP Insight Control Release Notes

• HP Virtual Connect Enterprise Manager Release Notes

Installation and configuration • HP Insight Management Installation and Configuration Guide

• HP Insight Management Preinstallation Worksheet

• HP Insight Management Quick Installation Guide
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Installation and configuration: HP-UX CMS

DocumentTopic

• HP Insight Management Support MatrixRequirements, feature support,
compatibility

• HP Matrix Operating Environment Release NotesRelease notes

• HP Matrix Operating Environment for HP-UX Installation and Configuration GuideInstallation and configuration

Using Matrix OE

DocumentTopic

Getting started • HP Matrix Operating Environment Getting Started Guide

• HP Insight Management Getting Started Guide

• HP Insight Control Getting Started Guide

User guides • HP Matrix Operating Environment Logical Server Management User Guide

• HP Capacity Advisor User Guide

• HP Application Discovery User Guide

• HP Global Workload Manager User Guide

• HP Integrity Virtual Machines Manager User Guide

• HP Insight Control Server Migration User Guide

• HP Insight Control Virtual Machine Management User Guide

• HP Insight Control Performance Management User Guide

• HP Storage Provisioning Manager (SPM) User Guide

• HP Matrix Operating Environment Infrastructure Orchestration User Guide

• HP Insight Control Power Management User Guide

• HP Matrix Operating Environment Recovery Management User Guide

• HP Insight Control Server Deployment User Guide

• HP Virtual Connect Enterprise Manager User Guide

Visit the Matrix OE information library.White papers

Web sites

Information and solutions
Reference Architectures for
Application Deployment in
Virtualized Environments

http://www.hp.com/go/idvsera

HP Business Support Center http://www.hp.com/bizsupport
Large Enterprise Business http://www.hp.com/go/enterprise

Products
HP Matrix Operating Environment http://www.hp.com/go/matrixoe
Matrix Operating Environment
Information Library

http://www.hp.com/go/matrixoe/docs

HP Insight Management http://www.hp.com/go/insightmanagement
HP Insight Control http://www.hp.com/go/insightcontrol/
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HP Matrix Operating Environment
infrastructure orchestration

http://www.hp.com/go/matrixoe

HP Matrix Operating Environment
recovery management

http://www.hp.com/go/matrixoe

HP Virtual Connect Enterprise
Manager

http://www.hp.com/go/vcem/

HP Systems Insight Manager http://www.hp.com/go/insightmanagement/sim/
HP CloudSystem Matrix http://www.hp.com/go/matrix

Command references (manpages)
Matrix Operating Environment and related products include manpages for HP-UX and Linux systems
and command reference pages for Microsoft Windows systems. These pages provide details about
commands, file formats, and related information. See“Command reference” (page 41) for command
reference pages included with this document. The following tables list additional reference pages
related to Matrix OE.

Reference pages installed on the CMS

DescriptionReference page

Set advanced options for Capacity Advisor agentless data collection, and view a
list of systems configured for agentless data collection (Windows CMS only)

capagentlesscfg(1M)

Configure Capacity Advisor benchmark CPU scaling to normalize collected datacapcustombenchmark(1M)

Format of Capacity Advisor custom benchmark database filescapcustombenchmark(4)

Export HP Performance Agent (formerly HP OpenView Performance Agent, or
OVPA) system data from managed systems and import into Capacity Advisor

capovpaextract(1M)

Export HP Performance Management Pack (PMP) system data from specified
managed systems and import the data into Capacity Advisor (Windows CMS
only)

cappmpextract

Import, export, display, invalidate and remove Capacity Advisor data for workloads
or systems

capprofile(1M)

Format of Capacity Advisor import and export filescapprofile(4)

Global Workload Managergwlm(1M)

Overview of Global Workload Managergwlm(5)

Global Workload Manager (gWLM) daemongwlmcmsd(1M)

Produce advanced textual summary reports for workload resource utilizationgwlmreport(1M)

Secure network communications for Global Workload Managergwlmsslconfig(1M)
gwlmimportkey(1M)
gwlmexportkey(1M)

Configure or unconfigure the Insight managed system setup wizardmsswinitconfig(1M)

Overview of XML file structure for Global Workload Managergwlmxml(4)

Help resolve Matrix OEconfiguration problemsvseassist(1M) (page 42)

Configure or unconfigure the Matrix OE softwarevseinitconfig(1M)

Manage licenses to use (LTUs) on HP Integrity and HP 9000 systemsvselicense(1M) (page 47)
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Reference pages installed with agent software on managed systems

DescriptionReference page

Control Application Discovery certificates from the managed nodeagent_config(1M)

Control or modify the operation of the Application Discovery agentamgrd(1M)

Global Workload Manager (gWLM) agentgwlmagent(1M)

Place a process in a gWLM workloadgwlmplace(1M)

Send metric data to gWLM for use in a custom policygwlmsend(1M)

Secure network communications for Global Workload Managergwlmsslconfig(1M)
gwlmimportkey(1M)
gwlmexportkey(1M)

Display status for the managed node's agent, SRD and license Managergwlmstatus(1M)

(HP-UX) system utilization data collection daemonutild(1M)

(Linux) system utilization data collection daemonutild(8)

(Windows) Utilization Provider Service (document installed in \Program Files\
Hewlett-Packard\UtilProvider\doc)

UPService.pdf

Reference page installed on cell-based complexes

DescriptionReference page

Start Partition Managerparmgr(1M)

Reference pages installed on systems running HP Integrity Virtual Machines

DescriptionReference page

About Integrity Virtual Machineshpvm(5)

Create a cloned copy of an Integrity virtual machinehpvmclone(1M)

Collect crash dumps, logs, system status, and configuration on guests and the Integrity VM Hosthpvmcollect(1M)

Connect to the console of an Integrity virtual machinehpvmconsole(1M)

Create a new Integrity virtual machinehpvmcreate(1M)

Manage the Integrity VM device databasehpvmdevmgmt(1M)

Display information about the Integrity VM environmenthpvminfo(1M)

Rename or modify the attributes of an Integrity virtual machinehpvmmodify(1M)

Move a virtual machine to another Integrity VM Host systemhpvmmigrate(1M)

Configure virtual network deviceshpvmnet(1M)

Remove an Integrity virtual machinehpvmremove(1M)

Start an Integrity virtual machinehpvmstart(1M)

Display status of one or more Integrity virtual machineshpvmstatus(1M)

Stop an Integrity virtual machinehpvmstop(1M)
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Selected Systems Insight Manager reference pages

DescriptionReference page

Configure the agent to work with a CMSmxagentconfig(1M)

Add, remove or list authorizations in Systems Insight Managermxauth(1M)

Manage global settings in Systems Insight Managermxglobalsettings(1M)

Perform initial configuration of the servermxinitconfig(1M)

Add, modify, identify, remove or list nodes in Systems Insight Managermxnode(1M)

Start Systems Insight Manager and the TomCat webservermxstart(1M)

Display or return (via exit code) the current ready/not-ready state of Systems Insight
Manager

mxstatus(1M)

Stop Systems Insight Manager and the TomCat webservermxstop(1M)

Add, modify, remove or list users in Systems Insight Managermxuser(1M)

Typographic conventions
This document uses the following typographic conventions.
Book Title Title of a book or other document.
Linked Title Title that is a hyperlink to a book or other document.
http://www.hp.com A Web site address that is a hyperlink to the site.
Command Command name or qualified command phrase.
user input Commands and other text that you type.
computer output Text displayed by the computer.
Enter The name of a keyboard key. Note that Return and Enter both refer

to the same key. A sequence such as Ctrl+A indicates that you must
hold down the key labeled Ctrl while pressing the A key.

term A term that is defined in the glossary and links to a glossary definition.
variable The name of an environment variable, for example PATH or errno.
value A value that you may replace in a command or function, or information

in a display that represents several possible values.
find(1) HP-UX manpage. In this example, “find” is the manpage name and

“1” is the manpage section.
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vseassist(1M)
NAME
vseassist -- Help Resolve Matrix OE Configuration Problems

SYNOPSIS
Path (HP-UX): /opt/vse/bin/vseassist
Path (Windows): install-path\bin\vseassist.exe
vseassist -a [-q] [ -n nodename | -g collectionname ]...
vseassist -c [-q]
vseassist { -l | -r } [-q] { -n nodename | -g collectionname }...
vseassist -s [-q] -h cms

DESCRIPTION
The vseassist command performs a number of checks to identify configuration problems in your
installation of HP Matrix Operating Environment. This command checks the software configuration
on the HP SIM Central Management Server (CMS), the communication between the CMS and
managed systems, and the configuration of the software on managed systems. A summary of results
is displayed and detailed results are written to a log file, along with recommendations for resolving
any problems found.
You can execute vseassist from the Matrix OE graphical user interface, from the command line
on the CMS, or from the command line on a managed system. HP recommends the following
diagnostic procedure:
1. If you have Administrator (root) access to the CMS, execute the following command from

the command line:
vseassist -a

This will check the configuration of the CMS, communication with all systems in the All VSE
Resources collection, and the configuration on those systems. Refer to the summary output
and examine the log file for any problems. Follow the resolution steps in the log file to fix any
problems that were found.
Fix problems in the CMS configuration first. You can verify that you have fixed those problems
by executing the following command from the CMS command line:
vseassist -c

You can also run this command directly from the Matrix OE user interface. From the Diagnose
menu, select Troubleshoot Matrix Operating Environment, then select Check
CMS Configuration.

2. After you have resolved all problems with the CMS configuration, check to see if there are
any remaining communication issues with the managed systems. From the CMS command
line, specify the HP SIM nodenames or system collection names of your managed systems
using the following command:
vseassist -l { -n nodename | -g collectionname ...}
Or, from the Matrix OE user interface, select the managed systems, then from the Diagnose
menu, select Troubleshoot Matrix Operating Environment, then select Check
CMS to Managed Node Communication.

3. After you have resolved the communication issues between the CMS and your managed
systems, check the configuration on those systems. From the CMS command line, specify the
HP SIM nodenames or system collection names of your managed systems using the following
command:
vseassist -r { -n nodename | -g collectionname ...}
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Or, from the Matrix OE user interface, select the managed systems, then from the Diagnose
menu, select Troubleshoot Matrix Operating Environment, then select Check
Managed Node Configuration.

4. If you are unable to resolve issues with one of your managed systems, you can install or copy
vseassist to the managed system and run it from the command line there. In the following
command, replace cms with the fully qualified domain name of the CMS:
vseassist -s -h cms

Options
If no options are specified, the command syntax is displayed and the command exits with return
code 3.
The vseassist command recognizes the following options. For each option, a mnemonic is
shown in parentheses to help you remember the option letter.
-a (All) Perform all checks:

1. Check the configuration of the CMS (as with the -c option).
2. Check the communication between the CMS and the specified

managed systems (as with the -l option). If no managed systems
are specified, then perform this check on all systems in the All
VSE Resources collection.

3. Check the configuration of the specified managed systems (as
with the -r option). If no managed systems are specified, then
perform this check on all compatible systems in the All VSE
Resources collection.

-c (CMS) Check the configuration of the CMS.
Note: For a Windows CMS, if IOAssist is installed, additional IOAssist
resource and CMS configuration checks will be launched.

-l (Link) From the CMS, check the communication between the CMS and
the managed systems specified by the -n and -g options. Some of
the problems detected with this option include expired licenses, no
open WBEM ports, and improperly configured SSH authentication.
These checks will verify that the CMS can communicate with the
managed systems in order to perform management functions.
This option requires one or more -n or -g options.
Note: On Windows and HP-UX CMS, vseassist will obtain the port
on which to attempt managed node communication from the file
globalsettings.props (see FILES section below). If no port
configuration is present, port 22 will be used.

-r (Remote) From the CMS, check the configuration of the HP-UX or
Windows managed systems specified by the -n and -g options
(vseassist does not provide configuration checks for Linux managed
systems). This option uses mxexec to copy the vseassist command
to the managed systems, where it is executed with the -s option.
In order for the -r option to succeed, the CMS must be able to
communicate with the managed systems (as checked by the -l option).
This option requires one or more -n or -g options.

-n nodename (Node) Specifies the name of a managed system using the node name
by which the system is known to the CMS (as reported by mxnode(1M)).
Multiple -n and -g options can be used to specify multiple systems.
Note: This command is only designed to diagnose problems with sytems
that are part of the All VSE Resources collection. Applying this
command to other resources using -n or -g options will not produce
useful results.

43



-g collectionname (Group) Specifies the name of a collection of systems known to the
CMS. The specified checks will be performed for each of the managed
systems in the collection. Multiple -n and -g options can be used to
specify multiple systems.
Note: System or collection names that include spaces must be enclosed
in quotes.
Refer to mxquery(1M) for more information about collections under HP
SIM.

-q (Quiet) No output will be generated on stdout or stderr. The results
will still be logged to the vseassist.log file.

-s (System) This option is used when running vseassist directly on
HP-UX or Windows managed systems (vseassist does not provide
configuration checks for Linux managed systems). Some of the problems
detected with this option include missing WBEM providers, stalled
WBEM process, and missing required patches. On an HP-UX managed
system, WBEM services checks will be performed by wbemassist if
wbemassist version 1.1 or later is installed. Otherwise vseassist
will use its own built-in WBEM checks.
Note: wbemassist checks for problems in HP-UX WBEMServices and
recommends solutions. It does not perform checks on WBEM Providers
or other services that use the CIM server. For more information, see
wbemassist(1M).
When you use vseassist with the -r option on the CMS, mxexec
will remotely execute vseassist on the managed systems using the
-s option.

-h cms (Host) Specifies the fully qualified domain name of the CMS that is
managing the system. This option is passed to the remote execution
of vseassist when you use the -r option on the CMS.

Installation
The vseassist command is installed on the CMS when Matrix OE is installed.

RETURN VALUES
0 The command completed successfully and no FAIL results were found.
1 The command completed successfully and one or more FAIL results were found.
2 Warnings, but no FAIL results were found.
3 Incorrect options were specified; the command syntax is displayed.
4 An unexpected internal error occurred. Contact your HP Support Representative, your HP

Services Representative, or your authorized HP reseller for assistance.

EXAMPLES
The specific checks performed may vary by operating system and system type of the CMS and
managed systems. The following examples show the kind of output that is produced, but the details
may be different in your environment.
Check the configuration of a CMS named unixsys:
# vseassist -c
Version: 7.0

+-----------------------------------------------------------------------------------------------+
|                  Performing CMS configuration verification                                    |
+-----------------------------------------------------------------------------------------------+

  unixsys:
    HP SIM running.........................................................................[PASS]
    HP SIM memory configuration............................................................[PASS]
    HP Matrix Operating Environment running................................................[PASS]
    Localhost name resolution..............................................................[PASS]
    Matrix OE manageable systems discovered in HP SIM......................................[PASS]
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    Application Discovery server running...................................................[PASS]
    File system free space.................................................................[PASS]
    Java JRE installed.....................................................................[PASS]
    Virtual Machine Management runnning....................................................[PASS]
    VMM responsive.........................................................................[WARN]
      WARNING:    HP SIM has discovered one or more virtual machine hosts 
                  servers, but the VMM plugin is not fully configured to 
                  manage the following servers: palacio . 
      RESOLUTION: - Verify if the HP Management Agents are installed (for 
                  SNMP and proper HP SIM discovery); 

                  - Verify if VMM agent has been installed; It's possible to 
                  install that via the "Deploy -> Deploy Drivers, 
                  Firmwares and Agents -> Install VMM Agent" menu; 

                  - Verify if the system is licensed for VMM; 

                  - Verify if the system is registered for VMM, if not 
                  register the VM host via the "Configure -> Virtual 
                  Machine Host Registration" menu or register the VM via 
                  the native virtualization console and Identify the 
                  system using "Options->Identify Systems" menu.
    Virtual Connect Enterprise Manager responsive.........................................[PASS]
    Logical Server Automation installed...................................................[PASS]

    Running infrastructure orchestration (IO) Checks......................................[PASS]

Result Summary:
  13 verification check(s) performed on 1 system(s)
  12 check(s) passed
  0 check(s) failed
  1 check(s) warned
  0 check(s) not applicable

See log for details: C:\Program Files\HP\Virtual Server Environment\logs\vseassist.log

Check the communication from the CMS to the managed system named system:
# vseassist -l -n system

Version: 7.0

+---------------------------------------------------------------------------------------------+
|        Performing link verification of managed system(s) from the CMS                       |
+---------------------------------------------------------------------------------------------+

  system:
    Managed system hostname resolution...................................................[PASS]
    WBEM port open.......................................................................[PASS]
    WBEM authentication..................................................................[PASS]
    SSH port open........................................................................[PASS]
    SSH authentication...................................................................[PASS]
    SNMP port open.......................................................................[PASS]
    Trial or permanent license applied...................................................[PASS]
    VMM accessibility....................................................................[N/A ]
    Capacity Advisor data collection.....................................................[PASS]
    Check VMware ESX version.............................................................[N/A ]

Result Summary:
  8 verification check(s) performed on 1 system(s)
  8 check(s) passed
  0 check(s) failed
  0 check(s) warned
  2 check(s) not applicable

See log for details: C:\Program Files\HP\Virtual Server Environment\logs\vseassist.log

AUTHORS
vseassist was developed by Hewlett-Packard Company.

DOCUMENT LAST UPDATED
January 2012

MESSAGES
The following message may be displayed when running managed system configuration checks on
a 64–bit Windows managed system:
'chcp' is not recognized as an internal or external command,
operable program or batch file.

This is an issue with the remote command execution facility of HP SIM. The message can be ignored.
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FILES
Configuration settings, including communication port settings, are read from the following file:
HP-UX: /etc/opt/mx/config/globalsettings.props

Windows: install-path\config\globalsettings.props

Detailed results of the checks performed by vseassist are written to the log file. Examine the
log file for recommended steps to resolve any problems found.
Note: The log file is not automatically pruned.
HP-UX: /var/adm/syslog/vseassist.log

Windows: install-path\logs\vseassist.log

Linux: /var/log/vseassist.log

The default install-path on a Windows CMS is C:\Program Files\HP\Virtual Server
Environment, but this directory can be changed at installation time.

SEE ALSO
Matrix OE help
Matrix OE information library (http://www.hp.com/go/matrixoe/docs)
, mxexec(1M), mxnode(1M), mxquery(1M), vseinitconfig(1M), vselicense(1M), wbemassist(1M)
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vselicense(1M)
NAME
vselicense -- Manage licenses to use (LTUs) on HP Integrity and HP 9000 Systems

SYNOPSIS
Path (HP-UX): /opt/vse/bin/vselicense
Path (Windows): installation-directory\bin\vselicense
vselicense { -? | --help }
(Show command help)
vselicense --usage
(Show command syntax)
vselicense { -t | --tempLicense } { -n sys | --sys=sys }...
(Apply temporary trial licenses)
vselicense { -l key | --key=key } { -n sys | --sys=sys }... { -p prod |
--prod=prod }
(Migrate and apply Integrity Windows/Linux LTUs)
vselicense { -m | --migrate } [ -g | --gwlm ] { -n sys | --sys=sys }...
(Scan and migrate HP-UX LTUs)
vselicense { -m | --migrate } { -c count | --count=count } { -n sys |
--sys=sys }
(Correct the number of per-core/socket licenses assigned to a system)
vselicense { -m | --migrate } { -c 0 | --count=0 } { -n sys | --sys=sys }
(Remove all the licenses applied to a system)
vselicense { -s | --show }
(List the managed systems with migrated LTUs)

DESCRIPTION
The vselicense command is installed on the Central Management Server (CMS) with Matrix
OE. This command installs and removes Licenses to Use (LTUs) for Matrix Operating Environment
for HP-UX. It can also be used to correct the number of per-core or per-socket licenses that are
applied for LTUs.
This command applies only to HP Integrity systems running HP-UX, Linux, or Microsoft Windows
operating systems, and HP 9000 systems running HP-UX. It is not used for licenses based on “5x5”
keys (introduced with VSE Management Software version 4.0). It is only used for trial licenses
included with Matrix OE and for the LTUs in the following list. You may have these LTUs installed
from a previous version of HP Matrix Operating Environment (formerly known as HP Insight Dynamics
or VSE Management Software), or from the HP-UX VSE or DC Operating Environments.
T2786AC HP VSE Suite for HP-UX 11i LTU
T2784AC HP Capacity Advisor for HP-UX LTU
T2782AC HP Virtualization Manager for HP-UX LTU
T2762AA HP Global Workload Manager Agent LTU
T2807AC HP Capacity Advisor for Integrity Windows
T2806AC HP Virtualization Manager for Integrity Windows
T2785AC HP Capacity Advisor for Integrity Linux
T2783AC HP Virtualization Manager for Integrity Linux
Matrix OE licenses are now managed in the HP Systems Insight Manager (SIM) License Manager
database on the CMS. These licenses are encoded in a “5x5” key consisting of 5 blocks of 5
numbers or characters. These licenses are added to the CMS and applied to managed systems
through HP SIM.
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Licenses from previous releases of VSE Management Software and licenses included in the HP-UX
VSE or DC Operating Environments were installed directly on HP-UX managed systems. A license
scan procedure was then used to obtain the license information from the managed systems for use
on the CMS. LTUs for managed systems running Linux for HP Integrity and Microsoft Windows for
HP Integrity were installed as keys on the CMS.
Licenses from previous versions of the software and licenses included in the HP-UX VSE or DC
Operating Environments are automatically migrated to the License Manager database if they were
previously in use (the license had already been installed and scanned). If these licenses were never
installed or have not yet been scanned, you may be able to migrate them to License Manager
database using vselicense (see “Migrating previously unused licenses” below).
Correcting the number of licensed cores or sockets
Matrix OE for HP-UX products are licensed per core or socket on managed HP Integrity and HP
9000 systems. When licenses from a previous release or from the HP-UX Operating Environments
are migrated to the current version, the number of cores or sockets on the managed system is
determined via a WBEM query. The value returned is used as the number of licenses assigned to
that system. If the WBEM query is unsuccessful at determining the correct number, one license is
assigned.
You are responsible for verifying that the correct number of licenses are applied to your managed
systems, based on the number of cores or sockets in use. In order to remain in compliance with
your End User Licensing Agreement, you may need to correct the count assigned during the license
migration process. To correct the count assigned during migration, enter the following command
on the CMS:
vselicense -m -c count -n sys

where count is the correct number of per-core or per-socket licenses to assign for system sys.
Migrating previously unused licenses
If permitted by your licensing agreement with HP, unused licenses that were purchased for an
earlier release but have not yet been installed or scanned can be migrated to the License Manager
database and applied to a managed system by the vselicense command, using the following
procedures. These procedures should also be used to enable the LTUs included with the HP-UX
VSE or DC Operating Environments.
To scan for HP-UX LTUs to migrate and apply, follow these steps (this scan can also be performed
by the Insight managed system setup wizard and from the Matrix OE GUI):
1. Install the HP-UX LTUs that have unused licenses, or install the VSE or DC Operating

Environment, on the managed system.
2. Establish common WBEM credentials for communication between the CMS and the managed

systems, or configure SSH for use in HP SIM. In some previous versions of the software, SSH
was required in order to scan for HP-UX LTUs. This scan is now attempted using WBEM. SSH
will only be used if scanning via WBEM fails. For information about configuring WBEM
credentials and SSH, see the HP Matrix Operating Environment for HP-UX Installation and
Configuration Guide.
It is also possible to scan for the gWLM LTU (T2762AA) by communicating directly with the
gWLM agent if it is running on the managed system. However, this will provide no information
about the other LTUs. To perform this type of scan, use the -g or --gwlm option.

NOTE: The gWLM scanning option is only supported for gWLM agent versions earlier than
version 4.0.

3. Execute one of the following commands on the CMS (note that multiple -n sys options can
be specified):
• Scan for T2786AC, T2784AC, T2782AC, and T2762AA LTUs using WBEM or SSH:

vselicense -m -n sys

• Scan for T2762AA LTU by communicating with the running gWLM agent:
vselicense -m -g -n sys
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NOTE: This operation may take a long time to complete.

4. If necessary, correct the number of per-core or per-socket licenses assigned to the systems
using vselicense with the -m and -c options, as described above.

To migrate and apply unused HP Integrity Linux or HP Integrity Windows LTUs, follow these steps:
1. Execute the following command on the CMS (note that multiple -n sys options can be

specified):
vselicense -l key -n sys -p prod

where key is the license key provided with the LTU product prod.

NOTE: This operation may take a long time to complete.

2. If necessary, correct the number of per-core or per-socket licenses assigned to the systems
using vselicense with the -m and -c options, as described above.

NOTE: Changes made by vselicense may not show up in the product's user interface until
you refresh the data (click the Refresh Data link in Capacity Advisor, or the Refresh Data icon in
the Visualization tab).

After migration to the License Manager database, your previously purchased LTUs will appear in
the HP SIM License Manager under the following new license names:
Matrix Operating Environment for
HP-UX

Migrated from:
T2786AC HP VSE Suite for HP-UX 11i LTU

HP Matrix OE visualization Migrated from:
T2782AC HP Virtualization Manager for HP-UX LTU
T2806AC HP Virtualization Manager for Integrity Windows
T2783AC HP Virtualization Manager for Integrity Linux

Capacity Advisor Migrated from:
T2784AC HP Capacity Advisor for HP-UX LTU
T2807AC HP Capacity Advisor for Integrity Windows
T2785AC HP Capacity Advisor for Integrity Linux

HP Global Workload Manager
(gWLM)

Migrated from:
T2762AA HP Global Workload Manager Agent LTU

Use the HP SIM License Manager to view the status of these licenses (select Deploy -> License
Manager... from the HP SIM menu, then select one of the new license names, as shown in the
preceding list).
Options
The vselicense command recognizes the following options.
-t|--tempLicense Apply a trial license forMatrix OE for HP-UX to the systems

identified by the -n options. When Matrix OE is installed on
the CMS, 10 trial licenses for Matrix OE for HP-UX are included
in the License Manager database. These licenses can be
applied to HP Integrity and HP 9000 systems. Each trial license
is valid for 90 days after it is applied to a managed system.
To continue to manage these systems beyond the trial period,
permanent licenses must be purchased.

-l key|--key=key Install the license key for the LTU product identified by the -p
option on the systems identified by the -n options.

-n sys|--sys=sys The system name, as identified in HP SIM.
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NOTE: HP Integrity virtual machines are licensed through the
VM Host. You cannot specify a virtual machine as the target
of a vselicense command. Instead, apply the command to
the VM Host system.

-p prod|--prod=prod The product number of the LTU being installed or migrated. For
example, T2783AC is the product number for the Virtualization
Manager LTU for HP Integrity managed systems running Linux.

-g|--gwlm Communicate directly with the gWLM agent running on the
managed system when scanning for the gWLM LTU. This option
should only be used if WBEM and SSH are not configured for
use. When using this option, the scan can only detect the
gWLM LTU (T2762AA). No information will be returned about
other LTUs. This option is only supported for gWLM agent
versions earlier than version 4.0.

-m|--migrate Migrate LTUs to the HP SIM License Manager database.
-c count|--count=count Set the number of per-core or per-socket licenses to apply to

the system identified by the -n option. This option is only valid
for previously migrated LTUs on the specified system. A count
value of 0 removes all migrated LTUs for that system from the
License Manager database.

-s|--show List the managed systems that have licenses that have been
migrated from previous software releases.

RETURN VALUES
0 The command completed successfully; no errors were detected.
1 An error occurred and the command did not complete successfully.
2 A warning occurred. See command output for details.

EXAMPLES
Apply licenses for the HP Integrity Linux Virtualization Manager (product T2783AC) on the managed
system that is identified in HP SIM as linsys1. The key value was obtained from HP when the
LTU was purchased.
vselicense -l key -n linsys1 -p T2783AC

Apply licenses for LTUs installed on an HP-UX managed system named uxsys2. The command
uses WBEM (or SSH if WBEM scan fails) to scan for the LTU(s) installed on the system.
vselicense -m -n uxsys2

Use gWLM to scan and apply T2762AA licenses on an HP-UX managed system.
vselicense -m -g -n uxsys3

Correct the number of per-core or per-socket licenses to 4 for a system with previously migrated
licenses.
vselicense -m -c 4 -n uxsys2

Remove all the licenses that were previously migrated and assigned to the managed system
winsys4.
vselicense -m -c 0 -n winsys4

AUTHORS
vselicense was developed by Hewlett-Packard Company.
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DOCUMENT LAST UPDATED
January 2012

SEE ALSO
Additional information is available in the “License Management” topic of the Matrix OE help, and
in the following documents:
vseinitconfig(1M), HP Matrix Operating Environment Getting Started Guide, HP Matrix Operating
Environment for HP-UX Installation and Configuration Guide, HP Insight Management Installation
and Configuration Guide.
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Glossary
active logical
server

A logical server that has been bound to both a managed system in HP Systems Insight Manager
and a workload, and is bound to specific storage. Active logical servers can be in one of two
states: powered on or powered off. An active logical server can be moved from one location to
another and its characteristics can be modified.

agent A program that regularly gathers information or performs some other service without the user's
immediate presence.

application A logically related set of processes active on a system (a running application) and/or a logically
related set of files on a machine disk (an installed application).

BladeSystem The HP product portfolio of form factor computing devices that provide versatile computing
configurations, integrated network connectivity, and power management capabilities. BladeSystem
options are available in both the Integrity and Proliant product lines.

BladeSystem
enclosure

Hardware solution that provides a flexible selection of half- or full-size server blades and associated
components (such as integrated connectivity to storage and data networks, and shared power
subsystems) into a single unit.

BladeSystem
Integrated
Manager

A software component in HP Systems Insight Manager that enables users to navigate the blade
servers, enclosure infrastructures, racks, and integrated switches in their BladeSystem environment
by way of pictorial and hierarchical tree representations.

callout icons Graphical icons that display in the right-hand corner of compartments or subcompartments.
Information callout icons show the system or workload attributes. Meter callout icons show
expanded information about the utilization meters that appear to the left of the icon. The utilization
meters display the recent utilization metrics for CPU, memory, disk, and LAN. See Matrix OE
visualization online help for explanation of icons appearing on the Visualization tab.

cell A circuit board that contains processors and memory, all controlled by a cell controller (CC). A
cell is the basic building block of an nPartition in a complex.

cell-based server A server in which all cores and memory are contained in cells, each of which can be assigned
for exclusive use by an nPartition. Each nPartition runs its own instance of an operating system.

CMS Central management server. A system in a server management domain that runs HP Systems
Insight Manager (HP SIM). All central operations within HP SIM are initiated from this system.

compartment An nPartition, virtual partition, virtual machine, or resource partition for which resources are
allocated by HP Global Workload Manager (gWLM).
Multiple compartments are grouped to form a shared resource domain (SRD). The compartments
all share the resources of the SRD. A compartment can be in only one SRD. Each compartment
holds a workload. gWLM manages each workload's resource allocation by adjusting the resource
allocation of its compartment.
On the Matrix OE Visualization tab, compartments are represented by color. You can select the
entire compartment or individual members within a compartment, then select a drop-down menu
item to operate on the selected item.

complex A complex includes one or more cabinets that are cabled together and all of the hardware
resources that they contain. A complex has a single service processor.

core The actual data-processing engine within a processor. A single processor might have multiple
cores, and a core might support multiple execution threads.

FSS group Fair-Share Scheduler group. A group of processes that has its CPU allocation managed by the
HP-UX Fair Share Scheduler. FSS groups allow you to allocate fractions of cores, rather than only
whole cores, to the processes in the group.

GiCAP HP Global Instant Capacity. Software that enables you to move usage rights for Instant Capacity
components within a group of servers.

iCAP HP Instant Capacity. The product allows you to purchase and install additional processing power
through the use of a two-step purchase model. Initially, you purchase system components (cores,
cell boards, memory) at a fraction of the regular price because the usage rights are not included.
These Instant Capacity components are inactive but installed and ready for use. When extra
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capacity is needed, you pay the remainder of the regular price for the usage rights to activate
the components. If the regular price for the component is reduced by the time the usage rights
are purchased, the remainder price is proportionally reduced, providing additional savings.

logical server A logical server is the complete software image of a server, including operating system,
applications, configuration data, and metadata that you create and assign to operate on a
physical server or virtual machine. Logical servers simplify the provisioning, management, and
movement of servers; and they allow you to quickly populate an enclosure, load balance servers,
and evacuate servers in case of disaster. Using logical servers, you can provision resources only
when needed, increasing optimal utilization of limited compute resources. Logical servers are a
feature of the HP Matrix Operating Environment.

LTU License to use.
managed system A server or other system that can be managed and monitored by HP Insight Management software

from an HP Systems Insight Manager CMS. A system can be managed and monitored by more
than one CMS.

managed
workload

A workload that is managed by HP Global Workload Manager .

management
domain

A CMS and its managed systems.

monitored
workload

A workload that can be monitored by the HP Matrix Operating Environment, but has no policy
associated with it. Monitored workloads are not managed by HP Global Workload Manager.

nPartition A partition in a cell-based server that consists of one or more cells and one or more I/O
components. Each nPartition operates independently of other nPartitions and either runs a single
instance of an operating system or is further divided into virtual partitions.
nPartitions can be used as compartments managed by HP Global Workload Manager (gWLM)
as long as several requirements are met. Refer to the gWLM online help for a description of
nPartition requirements.

parked workload A workload that is not currently associated with a system. A workload becomes parked if its
system is set to “none” when it is created or later modified. A parked workload that was previously
associated with a system may have historical data associated with it from Capacity Advisor or
HP Global Workload Manager. As with any workload, the historical data is lost if the workload
is deleted.
When migrating a workload from one system to another, it may be useful to park the workload
(removing the association with the original system) until the new system becomes available. This
preserves the historical data for the workload across the migration.

partition A subset of server hardware that includes core, memory, and I/O resources on which an
operating system (OS) can be run. This type of partitioning allows a single server to run an
OS independently in each partition with isolation from other partitions.

1.

2. A resource partition, made up of either a Fair-Share Scheduler (FSS) group or a processor
set, that runs within a single OS. This type of partitioning controls resource allocations within
an OS.

policy A collection of rules and settings that control compute resources For example, an HP Global
Workload Manager (gWLM) policy can indicate the minimum and maximum amount of CPU
resources allowed for a workload, and a target to be achieved.
A single policy can be associated with multiple workloads.

provision A function that makes a component operational. Provisioning might include installing, upgrading,
loading, and configuring a software or hardware component. Provisioning a server includes
loading the appropriate software (operating system and applications), customizing and configuring
the system, and starting the server and its newly-loaded software. This makes the system ready
for operation.

PSET Processor set. A collection of processors grouped together for exclusive access by applications
assigned to that processor set. Each application runs only on processors in its assigned processor
set.
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resource partition A subset of the resources available to an operating system instance, isolated for use by specific
processes. A resource partition has its own process scheduler. CPU resources in the partition may
be allocated using Fair-Share Scheduler groups or processor sets. Policies for controlling the
allocation of resources to the partition can be set using HP Global Workload Manager.

server blades Thin, modular, self-contained computer servers, containing one or more microprocessors and
memory. Server blades are designed for high density and eliminate many components such as
power cords and network cables that are present in traditional rack-mount systems.

service processor An independent support processor for HP servers that support nPartitions. The service processor
provides a menu of service-level commands, plus commands to reset and reboot nPartitions and
configure various parameters.
The service processor in HP servers is sometimes called the management processor (MP) or the
guardian service processor (GSP).

Serviceguard
cluster

An HP Serviceguard cluster is a networked group of HP 9000 or HP Integrity servers (host systems
known as nodes) having sufficient redundancy of software and hardware that a single point of
failure will not significantly disrupt service.

Serviceguard
package

Packages are the means by which HP Serviceguard starts and halts configured applications. A
package is a collection of services, disk volumes and IP addresses that are managed by
Serviceguard to ensure they are available.

Serviceguard
workload

A monitored workload associated with a Serviceguard cluster and a particular package within
the cluster. The workload (and the utilization data reported) follows the package it is associated
with as it moves between the nodes of the cluster.

SMI-S Storage Management Initiative Specification. SMI-S delivers open storage network management
interface technology in order to have “all storage managed by the SMI interface” as the unifying
factor between all objects that must be managed in a storage area network and the tools used
to manage them.

socket (CPU socket). The physical chip carrier on the circuit board that houses a CPU chip. The CPU
may consist of multiple cores.

SRD Shared resource domain. A collection of compartments that share system resources managed by
HP Global Workload Manager (gWLM). The compartments can be nPartitions, virtual partitions,
virtual machines, processor sets (PSETs) or Fair-Share Scheduler (FSS) groups.
A server containing nPartitions can be an SRD as long as nPartition requirements are met.
A server or an nPartition divided into virtual partitions can be an SRD for its virtual partition
compartments. A VM Host can be an SRD to its virtual machines. Similarly, a server, an nPartition,
or a virtual partition containing PSETs can be an SRD for its PSET compartments. Finally, a server,
an nPartition, or a virtual partition containing FSS groups can be an SRD for its FSS-group
compartments.
A complex with nPartitions can hold multiple SRDs. For example, if the complex is divided into
nPartitions named Par1 and Par2, Par1's compartments could be virtual partitions, while Par2's
compartments are PSETs.

SSL Secure Sockets Layer. Protocol for validating identity and for creating an encrypted connection
between a server and a Web browser.

system A server, nPartition, virtual partition, or virtual machine that is running an instance of an
operating system.

1.

2. Entities on the network that communicate through TCP/IP or IPX. To manage a system, some
type of management protocol (for example, SNMP, DMI or WBEM) must be present on the
system. Examples of systems include servers, workstations, desktops, portables, routers,
switches, hubs and gateways.

TiCAP Temporary Instant Capacity. An HP product that enables customers to purchase prepaid core
activation rights for a specified (temporary) period of time. Temporary capacity is sold in 30
processing-day increments.

Utilization Provider The WBEM services provider for real-time utilization data from managed systems.
VCEM Virtual Connect Enterprise Manager. A management tool for defining a server connection profile

for each server bay. This profile establishes the media access control (MAC) addresses for all
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network interface controllers (NICs), the World Wide Names (WWNs) for all host bus adapters
(HBAs), and the SAN boot parameters. If the server blade in the server bay is replaced, the
configuration and connection profile stays constant.

virtual machine A software entity provided by HP Integrity Virtual Machines, VMware ESX, VMware ESXi, or
Microsoft Hyper-V. This technology allows a single server or nPartition (with Integrity Virtual
Machines) to act as a VM Host for multiple individual virtual machines, each running its own
instance of an operating system (referred to as a guest OS). Virtual machines are managed
systems in the HP Matrix Operating Environment.

virtual partition A software partition of a server, or of a single nPartition, where each virtual partition can run its
own instance of an operating system. A virtual partition cannot span an nPartition boundary.

VM Host A server running HP Integrity Virtual Machines, VMware ESX, VMware ESXi, or Microsoft Hyper-V
that provides multiple virtual machines, each running its own instance of an operating system.

vPars An HP software product that provides virtual partitions.
vPars monitor The program that manages the assignment of resources to virtual partitions in a vPars-enabled

system. To enable virtual partitions, the vPars monitor must be booted in place of a normal HP-UX
kernel. Each virtual partition running under the monitor then boots its own HP-UX kernel.

WBEM Web-Based Enterprise Management. A set of web-based information services standards developed
by the Distributed Management Task Force, Inc. A WBEM provider offers access to a resource.
WBEM clients send requests to providers to get information about and access to the registered
resources.

WMI Windows Management Instrumentation. HP Matrix Operating Environment uses WMI for data
collection from managed systems running Microsoft Windows. WMI queries and responses are
converted to WBEM through the WMI Mapper.

workload A collection of processes in a stand-alone server, nPartition compartment, virtual partition
compartment, or virtual machine compartment. HP Global Workload Manager (gWLM) extends
this concept to include processor set (PSET) compartments and Fair-Share Scheduler (FSS) group
compartments.
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